summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-04 13:34:14 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-04 13:34:14 +0000
commitc26c7ec1eef2055a7eae40810be251d4a1f18381 (patch)
tree423a339c875dee0a05e28fcc0ff920c09f1bc96c /dev-util/btyacc
parentVersion bump, security fix for IAX2 denial of service (AST-2009-006). Set mis... (diff)
downloadgentoo-2-c26c7ec1eef2055a7eae40810be251d4a1f18381.tar.gz
gentoo-2-c26c7ec1eef2055a7eae40810be251d4a1f18381.tar.bz2
gentoo-2-c26c7ec1eef2055a7eae40810be251d4a1f18381.zip
Respect CC (bug #243974), append to CFLAGS (but not -g), append to LDFLAGS, use system LD.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-util/btyacc')
-rw-r--r--dev-util/btyacc/ChangeLog11
-rw-r--r--dev-util/btyacc/btyacc-3.0-r1.ebuild36
-rw-r--r--dev-util/btyacc/files/btyacc-3.0-makefile.patch22
3 files changed, 67 insertions, 2 deletions
diff --git a/dev-util/btyacc/ChangeLog b/dev-util/btyacc/ChangeLog
index 1549d81c5414..1ec8a3b8299f 100644
--- a/dev-util/btyacc/ChangeLog
+++ b/dev-util/btyacc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/btyacc
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/btyacc/ChangeLog,v 1.9 2008/10/31 06:19:16 wormo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/btyacc/ChangeLog,v 1.10 2009/09/04 13:34:14 jer Exp $
+
+*btyacc-3.0-r1 (04 Sep 2009)
+
+ 04 Sep 2009; Jeroen Roovers <jer@gentoo.org> +btyacc-3.0-r1.ebuild,
+ +files/btyacc-3.0-makefile.patch:
+ Respect CC (bug #243974), append to CFLAGS (but not -g), append to
+ LDFLAGS, use system LD.
31 Oct 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+files/btyacc-3.0-includes.patch, btyacc-3.0.ebuild:
diff --git a/dev-util/btyacc/btyacc-3.0-r1.ebuild b/dev-util/btyacc/btyacc-3.0-r1.ebuild
new file mode 100644
index 000000000000..1e4f2efc7b2b
--- /dev/null
+++ b/dev-util/btyacc/btyacc-3.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/btyacc/btyacc-3.0-r1.ebuild,v 1.1 2009/09/04 13:34:14 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/./-}
+IUSE=""
+DESCRIPTION="Backtracking YACC - modified from Berkeley YACC"
+HOMEPAGE="http://www.siber.com/btyacc"
+SRC_URI="http://www.siber.com/btyacc/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp -av Makefile{,.orig}
+ epatch "${FILESDIR}/${P}-includes.patch"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin btyacc
+ dodoc README README.BYACC
+ newman manpage btyacc.1
+}
diff --git a/dev-util/btyacc/files/btyacc-3.0-makefile.patch b/dev-util/btyacc/files/btyacc-3.0-makefile.patch
new file mode 100644
index 000000000000..884b49f46b9d
--- /dev/null
+++ b/dev-util/btyacc/files/btyacc-3.0-makefile.patch
@@ -0,0 +1,22 @@
+Respect CC, append to CFLAGS (but not -g), append to LDFLAGS, use system LD -jer
+
+--- Makefile.orig 1999-07-15 19:40:12.000000000 +0200
++++ Makefile 2009-09-04 15:27:15.000000000 +0200
+@@ -8,14 +8,13 @@
+
+ HDRS = defs.h mstring.h
+
+-CFLAGS = -g -Wall -Wstrict-prototypes -Wmissing-prototypes
++CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes
+
+-LDFLAGS = -static
++LDFLAGS += -static
+
+ LIBS =
+
+-CC = gcc
+-LINKER = gcc
++LINKER = $(CC)
+ # LINKER = cl
+ # CC = cl
+