summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-12-18 19:33:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-12-18 19:33:54 +0000
commit00352892d18cc85fa6b777f9367cdafd6b74ef00 (patch)
treecee949096e46fd0d1036458c0bca9808a9fe43e0 /dev-util/buildbot-slave
parentVersion bump (diff)
downloadgentoo-2-00352892d18cc85fa6b777f9367cdafd6b74ef00.tar.gz
gentoo-2-00352892d18cc85fa6b777f9367cdafd6b74ef00.tar.bz2
gentoo-2-00352892d18cc85fa6b777f9367cdafd6b74ef00.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-util/buildbot-slave')
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index a4b58c20ba4d..929559c21607 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.64 2014/10/18 15:19:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.65 2014/12/18 19:33:54 hwoarang Exp $
+
+*buildbot-slave-0.8.10 (18 Dec 2014)
+
+ 18 Dec 2014; Markos Chandras <hwoarang@gentoo.org>
+ +buildbot-slave-0.8.10.ebuild:
+ Version bump
*buildbot-slave-0.8.9-r1 (18 Oct 2014)
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild
new file mode 100644
index 000000000000..f567176dd8a0
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.10.ebuild,v 1.1 2014/12/18 19:33:54 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 readme.gentoo systemd user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+PYTHON_MODNAME="buildslave"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+ systemd_dounit "${FILESDIR}/buildslave.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}