summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-03 19:39:25 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-03 19:39:25 +0000
commitbbaf1293bab34d85a03ea185655e9e79397e4559 (patch)
tree0a83b31ffcdc2234bad3430d6689a8de272ccd0b /dev-util/buildbot-slave
parentVersion bump buildbot to 0.8.4_p2. (diff)
downloadgentoo-2-bbaf1293bab34d85a03ea185655e9e79397e4559.tar.gz
gentoo-2-bbaf1293bab34d85a03ea185655e9e79397e4559.tar.bz2
gentoo-2-bbaf1293bab34d85a03ea185655e9e79397e4559.zip
Version bump buildbot-slave to 0.8.4.
(Portage version: 2.1.10.12/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/buildbot-slave')
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.4.ebuild56
-rw-r--r--dev-util/buildbot-slave/files/buildslave.initd4
3 files changed, 65 insertions, 3 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index f8d7e74065c3..3bdeb08c8e46 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.18 2011/08/22 10:05:37 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.19 2011/09/03 19:39:25 djc Exp $
+
+*buildbot-slave-0.8.4 (03 Sep 2011)
+
+ 03 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> +buildbot-slave-0.8.4.ebuild,
+ files/buildslave.initd:
+ Version bump to 0.8.4.
22 Aug 2011; Markus Duft <mduft@gentoo.org> buildbot-slave-0.8.3.ebuild:
keyworded ~x86-interix
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.4.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.4.ebuild
new file mode 100644
index 000000000000..db88ff9f5749
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.4.ebuild,v 1.1 2011/09/03 19:39:25 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial buildslave"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils eutils
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools
+ >=dev-python/twisted-2
+ !!<dev-util/buildbot-0.8.1
+ !<dev-util/buildbot-0.8.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+PYTHON_MODNAME="buildslave"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+}
+
+src_install() {
+ distutils_src_install
+
+ doman docs/buildslave.1 || die "doman failed"
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave || die "newconfd failed"
+ newinitd "${FILESDIR}/buildslave.initd" buildslave || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The \"buildbot\" user and the \"buildslave\" init script has been added"
+ elog "to support starting buildslave through Gentoo's init system. To use this,"
+ elog "set up your build slave following the documentation, make sure the"
+ elog "resulting directories are owned by the \"buildbot\" user and point"
+ elog "\"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can"
+ elog "run as a different user if desired. If you need to run more than one"
+ elog "build slave, just copy the scripts."
+}
diff --git a/dev-util/buildbot-slave/files/buildslave.initd b/dev-util/buildbot-slave/files/buildslave.initd
index 7408479d23a8..f14c14c4457c 100644
--- a/dev-util/buildbot-slave/files/buildslave.initd
+++ b/dev-util/buildbot-slave/files/buildslave.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -30,7 +30,7 @@ start() {
ebegin "Starting buildslave in ${BASEDIR}"
# We set HOME here to make something valid show up in the env of child
# processes spawned by the buildslave.
- start-stop-daemon --start -c "${USERNAME}" \
+ start-stop-daemon --start -u "${USERNAME}" \
--env HOME="${BASEDIR}" \
--exec /usr/bin/python -- /usr/bin/twistd \
--no_save \