summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-13 14:30:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-13 14:30:57 +0000
commit0979bb8915fb57eed8ed38258822176b7b8abf42 (patch)
tree79c5c6f25532754fe326a627ad6b2929041595c2 /dev-util/buildbot
parent* bump (diff)
downloadgentoo-2-0979bb8915fb57eed8ed38258822176b7b8abf42.tar.gz
gentoo-2-0979bb8915fb57eed8ed38258822176b7b8abf42.tar.bz2
gentoo-2-0979bb8915fb57eed8ed38258822176b7b8abf42.zip
Delete older, vulnerable ebuilds.
(Portage version: 14242-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/ChangeLog8
-rw-r--r--dev-util/buildbot/buildbot-0.7.10_p1.ebuild100
-rw-r--r--dev-util/buildbot/buildbot-0.7.5.ebuild87
-rw-r--r--dev-util/buildbot/buildbot-0.7.6.ebuild92
-rw-r--r--dev-util/buildbot/buildbot-0.7.7-r1.ebuild92
-rw-r--r--dev-util/buildbot/buildbot-0.7.9-r1.ebuild94
-rw-r--r--dev-util/buildbot/buildbot-0.7.9-r2.ebuild95
-rw-r--r--dev-util/buildbot/files/buildbot.initd48
8 files changed, 7 insertions, 609 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index e5a28780aa02..ca2e85a37395 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.50 2009/09/11 19:31:31 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.51 2009/09/13 14:30:56 arfrever Exp $
+
+ 13 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -buildbot-0.7.5.ebuild, -buildbot-0.7.6.ebuild, -buildbot-0.7.7-r1.ebuild,
+ -buildbot-0.7.9-r1.ebuild, -buildbot-0.7.9-r2.ebuild,
+ -buildbot-0.7.10_p1.ebuild, -files/buildbot.initd:
+ Delete older, vulnerable ebuilds.
11 Sep 2009; Markus Meier <maekke@gentoo.org> buildbot-0.7.11_p3.ebuild:
amd64 stable, bug #282855
diff --git a/dev-util/buildbot/buildbot-0.7.10_p1.ebuild b/dev-util/buildbot/buildbot-0.7.10_p1.ebuild
deleted file mode 100644
index 59135783e2d1..000000000000
--- a/dev-util/buildbot/buildbot-0.7.10_p1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.10_p1.ebuild,v 1.9 2009/06/17 20:10:33 jer Exp $
-
-EAPI=1
-NEED_PYTHON="2.4"
-
-MY_PV="${PV/_p/p}"
-MY_P="${PN}-${MY_PV}"
-
-inherit distutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE="doc irc mail manhole test"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- manhole? ( dev-python/twisted-conch )
- irc? ( dev-python/twisted-words )
- dev-python/twisted-web
- dev-python/twisted-mail"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r contrib
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e 's/@buildbot@/buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e 's/@buildbot@/buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.5.ebuild b/dev-util/buildbot/buildbot-0.7.5.ebuild
deleted file mode 100644
index 72b70e0b38ec..000000000000
--- a/dev-util/buildbot/buildbot-0.7.5.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.5.ebuild,v 1.13 2008/04/05 17:24:13 hawking Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/buildbot/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc irc mail test web"
-
-commondepend=">=dev-lang/python-2.3
- >=dev-python/twisted-2.0.1"
-RDEPEND="${commondepend}
- mail? ( dev-python/twisted-mail )
- irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
-DEPEND="${commondepend}
- test? ( dev-python/twisted-web )
- doc? ( dev-python/epydoc )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- if use doc; then
- doins -r docs/reference
- fi
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.6.ebuild b/dev-util/buildbot/buildbot-0.7.6.ebuild
deleted file mode 100644
index e77ff4cbf5ce..000000000000
--- a/dev-util/buildbot/buildbot-0.7.6.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.6.ebuild,v 1.5 2008/05/27 16:45:29 corsair Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/buildbot/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc irc mail test web"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.7-r1.ebuild b/dev-util/buildbot/buildbot-0.7.7-r1.ebuild
deleted file mode 100644
index 570a664aafe0..000000000000
--- a/dev-util/buildbot/buildbot-0.7.7-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.7-r1.ebuild,v 1.7 2008/11/04 23:15:34 vapier Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc irc mail test web"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e 's/@buildbot@/buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e 's/@buildbot@/buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.9-r1.ebuild b/dev-util/buildbot/buildbot-0.7.9-r1.ebuild
deleted file mode 100644
index 8cc941d1f368..000000000000
--- a/dev-util/buildbot/buildbot-0.7.9-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.9-r1.ebuild,v 1.1 2009/02/15 11:53:12 patrick Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc irc mail manhole test"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- manhole? ( dev-python/twisted-conch )
- irc? ( dev-python/twisted-words )
- dev-python/twisted-web
- dev-python/twisted-mail"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e 's/@buildbot@/buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e 's/@buildbot@/buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.9-r2.ebuild b/dev-util/buildbot/buildbot-0.7.9-r2.ebuild
deleted file mode 100644
index 391ffda9c293..000000000000
--- a/dev-util/buildbot/buildbot-0.7.9-r2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.9-r2.ebuild,v 1.1 2009/02/24 21:09:56 hawking Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc irc mail manhole test"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- manhole? ( dev-python/twisted-conch )
- irc? ( dev-python/twisted-words )
- dev-python/twisted-web
- dev-python/twisted-mail"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r contrib
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e 's/@buildbot@/buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e 's/@buildbot@/buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/files/buildbot.initd b/dev-util/buildbot/files/buildbot.initd
deleted file mode 100644
index bf11190b128f..000000000000
--- a/dev-util/buildbot/files/buildbot.initd
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/files/buildbot.initd,v 1.2 2006/11/02 20:03:49 marienz Exp $
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [[ -z "${BASEDIR}" ]]; then
- eerror "BASEDIR not set"
- return 1
- fi
- if [[ -z "${USERNAME}" ]]; then
- eerror "USERNAME not set"
- return 1
- fi
- if [[ ! -d "${BASEDIR}" ]]; then
- eerror "${BASEDIR} is not a directory"
- return 1
- fi
- if [[ ! -e "${BASEDIR}/buildbot.tac" ]]; then
- eerror "${BASEDIR} does not contain buildbot.tac"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting buildbot in ${BASEDIR}"
- # We set HOME here to make something valid show up in the env of child
- # processes spawned by the buildslave.
- start-stop-daemon --start -c "${USERNAME}" --quiet \
- --env HOME="${BASEDIR}" \
- --exec /usr/bin/twistd -- \
- --no_save \
- --logfile="${BASEDIR}/twistd.log" \
- --pidfile="${BASEDIR}/twistd.pid" \
- --python="${BASEDIR}/buildbot.tac"
- eend $?
-}
-
-stop() {
- ebegin "Stopping buildbot in ${BASEDIR}"
- start-stop-daemon --stop --quiet --pidfile "${BASEDIR}/twistd.pid"
- eend $?
-}