summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-02-06 18:15:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-02-06 18:15:35 +0000
commitc13025618bd0092facda61a3a4b03077fc3adac0 (patch)
tree67df97f9202ea8e64cff570fd1483fd0587d56dd /dev-util/buildbot
parentVersion bump for bug 455562 (diff)
downloadgentoo-2-c13025618bd0092facda61a3a4b03077fc3adac0.tar.gz
gentoo-2-c13025618bd0092facda61a3a4b03077fc3adac0.tar.bz2
gentoo-2-c13025618bd0092facda61a3a4b03077fc3adac0.zip
Pass --pidfile to start-stop-daemon so we can get proper init script status reports from rc-status
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/ChangeLog9
-rw-r--r--dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild113
-rw-r--r--dev-util/buildbot/files/buildmaster.initd3
3 files changed, 123 insertions, 2 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index ebcca040c5d4..8109e180d0b8 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.121 2013/01/26 16:36:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.122 2013/02/06 18:15:35 hwoarang Exp $
+
+*buildbot-0.8.7_p1-r1 (06 Feb 2013)
+
+ 06 Feb 2013; Markos Chandras <hwoarang@gentoo.org>
+ +buildbot-0.8.7_p1-r1.ebuild, files/buildmaster.initd:
+ Pass --pidfile to start-stop-daemon so we can get proper init script status
+ reports from rc-status
26 Jan 2013; Markos Chandras <hwoarang@gentoo.org> buildbot-0.8.7_p1.ebuild:
Rework code for the env file creation. Thanks to floppym@gentoo.org. Use EAPI5
diff --git a/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild b/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild
new file mode 100644
index 000000000000..439f48d47890
--- /dev/null
+++ b/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild,v 1.1 2013/02/06 18:15:35 hwoarang Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils user
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot build automation system"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples irc mail manhole test"
+
+# sqlite3 module of Python 2.5 is not supported.
+RDEPEND=">=dev-python/jinja-2.1
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
+ || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-python/pysqlite:2 )
+ >=dev-python/twisted-8.0.0
+ dev-python/twisted-web
+ dev-python/sqlalchemy
+ dev-python/sqlalchemy-migrate
+ irc? ( dev-python/twisted-words )
+ mail? ( dev-python/twisted-mail )
+ manhole? ( dev-python/twisted-conch )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ doc? ( sys-apps/texinfo )
+ test? (
+ dev-python/mock
+ dev-python/twisted-mail
+ dev-python/twisted-web
+ dev-python/twisted-words
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake buildbot.html buildbot.info
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ doman docs/buildbot.1
+
+ if use doc; then
+ dohtml -r docs/buildbot.html docs/images
+ doinfo docs/buildbot.info
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r contrib docs/examples
+ fi
+
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
+
+ # In case of multiple masters, it's possible to edit web files
+ # so all master can share the changes. So protect them!
+ # If something else need to be protected, please open a bug
+ # on http://bugs.gentoo.org
+ local cp
+ add_config_protect() {
+ cp+=" $(python_get_sitedir)/${PN}/status/web"
+ }
+ python_execute_function -q add_config_protect
+ echo "CONFIG_PROTECT=\"${cp}\"" \
+ > 85${PN} || die
+ doenvd 85${PN}
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The \"buildbot\" user and the \"buildmaster\" init script has been added"
+ elog "to support starting buildbot through Gentoo's init system. To use this,"
+ elog "set up your build master following the documentation, make sure the"
+ elog "resulting directories are owned by the \"buildbot\" user and point"
+ elog "\"${EROOT}etc/conf.d/buildmaster\" at the right location. The scripts can"
+ elog "run as a different user if desired. If you need to run more than one"
+ elog "build master, just copy the scripts."
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+}
diff --git a/dev-util/buildbot/files/buildmaster.initd b/dev-util/buildbot/files/buildmaster.initd
index ff0ab0d37641..08c921b022aa 100644
--- a/dev-util/buildbot/files/buildmaster.initd
+++ b/dev-util/buildbot/files/buildmaster.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -29,6 +29,7 @@ start() {
checkconfig || return 1
ebegin "Starting buildmaster in ${BASEDIR}"
start-stop-daemon --start -u "${USERNAME}" \
+ --pidfile "${BASEDIR}/buildmaster.pid" \
--exec /usr/bin/python -- /usr/bin/twistd \
--no_save \
--logfile="${BASEDIR}/twistd.log" \