summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2013-06-16 14:58:39 +0000
committerBrian Dolbec <dolsen@gentoo.org>2013-06-16 14:58:39 +0000
commit9cdf2c7abca96ac12467ef7399161c661916d088 (patch)
tree0d2ddf40aa586fba1dfd8eaa676a27f95512c384 /dev-util/catalyst/catalyst-2.9999.ebuild
parentcorrect setuotools in deps wrt Bug #473278 (diff)
downloadgentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.tar.gz
gentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.tar.bz2
gentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.zip
Add new 3.0 development branch ebuild, remove catalyst_3 branch ebuild
(Portage version: 2.2.0_alpha179_p5/cvs/Linux x86_64, signed Manifest commit with key 0x65E309F2189DB0B8)
Diffstat (limited to 'dev-util/catalyst/catalyst-2.9999.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-2.9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/catalyst/catalyst-2.9999.ebuild b/dev-util/catalyst/catalyst-2.9999.ebuild
new file mode 100644
index 000000000000..b451ee767753
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.9999.ebuild,v 1.11 2013/06/16 14:58:39 dolsen Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux."
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+EGIT_MASTER="master"
+EGIT_BRANCH="3.0"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache doc kernel_linux"
+
+KEYWORDS=""
+
+DEPEND="app-text/asciidoc
+ >=dev-python/snakeoil-0.5.2"
+
+RDEPEND="app-arch/lbzip2
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+}
+
+python_compile_all() {
+ # build the man pages and docs
+ emake
+}
+
+python_install_all(){
+ distutils-r1_python_install_all
+ if use doc; then
+ dodoc files/HOWTO.html files/docbook-xsl.css
+ fi
+}