summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-21 06:46:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-21 06:46:58 +0000
commit0c7d5cc43e95cce6599a18d002dc11f342d3820e (patch)
tree689a1e38c1f88c739ffbc69e3862eb39f3d3c236 /dev-util/catalyst
parentVersion bump (diff)
downloadgentoo-2-0c7d5cc43e95cce6599a18d002dc11f342d3820e.tar.gz
gentoo-2-0c7d5cc43e95cce6599a18d002dc11f342d3820e.tar.bz2
gentoo-2-0c7d5cc43e95cce6599a18d002dc11f342d3820e.zip
Updating to 2.0.6_pre9, since 2.0.6_pre8 introduced a bug which caused pkgcache to no longer work. Also, restoring 2.0.5 since it was the only stable version. Of course, repoman won't let me commit it straight to stable, so marking it ~arch across the board.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog11
-rw-r--r--dev-util/catalyst/catalyst-2.0.5.ebuild76
-rw-r--r--dev-util/catalyst/catalyst-2.0.6_pre9.ebuild94
3 files changed, 180 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index ec7581bb317e..140cb7990903 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.188 2008/02/20 20:57:27 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.189 2008/02/21 06:46:58 wolf31o2 Exp $
+
+*catalyst-2.0.6_pre9 (21 Feb 2008)
+
+ 21 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.5.ebuild, +catalyst-2.0.6_pre9.ebuild:
+ Updating to 2.0.6_pre9, since 2.0.6_pre8 introduced a bug which caused
+ pkgcache to no longer work. Also, restoring 2.0.5 since it was the only
+ stable version. Of course, repoman won't let me commit it straight to
+ stable, so marking it ~arch across the board.
*catalyst-2.0.6_pre8 (20 Feb 2008)
diff --git a/dev-util/catalyst/catalyst-2.0.5.ebuild b/dev-util/catalyst/catalyst-2.0.5.ebuild
new file mode 100644
index 000000000000..a39df27f0340
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.5.ebuild,v 1.4 2008/02/21 06:46:58 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="release metatool used for creating Gentoo releases"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/catalyst-2.0.6_pre9.ebuild b/dev-util/catalyst/catalyst-2.0.6_pre9.ebuild
new file mode 100644
index 000000000000..49e3c1bf066b
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.6_pre9.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6_pre9.ebuild,v 1.1 2008/02/21 06:46:58 wolf31o2 Exp $
+
+# catalyst-9999 -> latest SVN
+# catalyst-9999.REV -> use SVN REV
+# catalyst-VER -> normal catalyst release
+
+if [[ ${PV} == 9999* ]]
+then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://anonsvn.gentoo.org/catalyst/trunk"
+ inherit subversion eutils multilib
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+else
+ inherit eutils multilib
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+fi
+
+DESCRIPTION="release metatool used for creating Gentoo releases"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+#KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ doins -r arch modules livecd || die "copying files"
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}