summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-06-25 02:06:28 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-06-25 02:06:28 +0000
commita3246ef0de5fcd5787cdb130e9b118374dac695f (patch)
tree4d2fbd34530961046aa7f44fcf730b20f506ee2b /dev-util/ccache
parentPartial fix for #3029. (diff)
downloadgentoo-2-a3246ef0de5fcd5787cdb130e9b118374dac695f.tar.gz
gentoo-2-a3246ef0de5fcd5787cdb130e9b118374dac695f.tar.bz2
gentoo-2-a3246ef0de5fcd5787cdb130e9b118374dac695f.zip
New ccache 1.9 designed to be auto-enabled with Portage 2.0.6+. Some significant
changes here.
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog23
-rw-r--r--dev-util/ccache/ccache-1.8.ebuild22
-rw-r--r--dev-util/ccache/ccache-1.9.ebuild47
-rw-r--r--dev-util/ccache/files/digest-ccache-1.81
-rw-r--r--dev-util/ccache/files/digest-ccache-1.91
5 files changed, 63 insertions, 31 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 04cfa5e12f8b..bfb78bbcdce1 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-util/ccache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.1 2002/05/01 05:56:02 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.2 2002/06/25 02:06:28 drobbins Exp $
+
+*ccache-1.9 (24 Jun 2002)
+
+ 24 Jun 2002; Daniel Robbins <drobbins@gentoo.org> : updating to 1.9.
+
+*ccache-1.8-r1 (24 Jun 2002)
+
+ 24 Jun 2002; Daniel Robbins <drobbins@gentoo.org> : new ebuild that installs
+ ccache into /usr/bin/ccache/ccache and creates /usr/bin/ccache/gcc and cc
+ symlinks automatically. Also creates /root/.ccache dir if it doesn't exist.
+ This version is designed to play nicely with Portage 2.0.6. Portage 2.0.6+
+ will auto-detect and use ccache if it is available :)
*ccache-1.8 (30 Apr 2002)
- 30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog : Initial
+ release submitted by Paul Belt <gaarde@yahoo.com>. Thanks Paul!
diff --git a/dev-util/ccache/ccache-1.8.ebuild b/dev-util/ccache/ccache-1.8.ebuild
deleted file mode 100644
index e2eb4047dcf5..000000000000
--- a/dev-util/ccache/ccache-1.8.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Paul Belt <gaarde@yahoo.com>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.8.ebuild,v 1.1 2002/05/01 05:56:02 rphillips Exp $
-
-DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
-compiler to safely cache compilation output. When the same code is compiled
-again the cached output is used giving a significant speedup."
-SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
-HOMEPAGE="http://ccache.samba.org/"
-
-src_compile() {
- ./configure \
- --prefix=${D}/usr || die
- make || die
-}
-
-src_install () {
- dobin ccache
- doman ccache.1
- dodoc COPYING README
-}
diff --git a/dev-util/ccache/ccache-1.9.ebuild b/dev-util/ccache/ccache-1.9.ebuild
new file mode 100644
index 000000000000..31f340a745e3
--- /dev/null
+++ b/dev-util/ccache/ccache-1.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.9.ebuild,v 1.1 2002/06/25 02:06:28 drobbins Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+KEYWORDS="x86"
+
+# Note: this version is designed to be auto-detected and used if you happen to have Portage
+# 2.0.6+ installed.
+
+src_compile() {
+ ./configure --prefix=${D}/usr || die
+ make || die
+}
+
+src_install () {
+ exeinto /usr/bin/ccache
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+ cd ${D}/usr/bin/ccache
+ ln -s ccache gcc
+ ln -s ccache cc
+ ln -s ccache c++
+ ln -s ccache g++
+ ln -s ccache ${CHOST}-c++
+ ln -s ccache ${CHOST}-g++
+ ln -s ccache ${CHOST}-gcc
+}
+
+pkg_postinst() {
+ if [ ! -d ${ROOT}root/.ccache ]
+ then
+ install -d -m0700 ${ROOT}root/.ccache
+ fi
+ einfo "To use ccache, add /usr/bin/ccache to your path before /usr/bin."
+ einfo "Portage 2.0.6+ will automatically take advantage of ccache with no additional steps."
+ einfo "If this is your first install of ccache, type something like this to set a maximum"
+ einfo "cache size of 2GB (or whatever you desire):"
+ einfo "# /usr/bin/ccache/ccache -M 2G"
+}
+
+
diff --git a/dev-util/ccache/files/digest-ccache-1.8 b/dev-util/ccache/files/digest-ccache-1.8
deleted file mode 100644
index 052a441a06f0..000000000000
--- a/dev-util/ccache/files/digest-ccache-1.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 043d592b23753d8beb85e6a228b74c16 ccache-1.8.tar.gz 62148
diff --git a/dev-util/ccache/files/digest-ccache-1.9 b/dev-util/ccache/files/digest-ccache-1.9
new file mode 100644
index 000000000000..a561ea71b898
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-1.9
@@ -0,0 +1 @@
+MD5 8e73f607accc13da52934303140d555e ccache-1.9.tar.gz 62583