summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-01-06 20:31:55 +0000
committerAron Griffis <agriffis@gentoo.org>2003-01-06 20:31:55 +0000
commitddc113180fed54adc24bab20734c3cde80b0d398 (patch)
tree7b5d6903b6c61a14329fd745748692380ef056b1 /dev-util/ccache
parentremoved leading spaces (diff)
downloadgentoo-2-ddc113180fed54adc24bab20734c3cde80b0d398.tar.gz
gentoo-2-ddc113180fed54adc24bab20734c3cde80b0d398.tar.bz2
gentoo-2-ddc113180fed54adc24bab20734c3cde80b0d398.zip
Fix ccache bugs due to gcc removal from /usr/bin
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog9
-rw-r--r--dev-util/ccache/ccache-1.9-r2.ebuild51
-rw-r--r--dev-util/ccache/files/digest-ccache-1.9-r21
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 9b8682bae562..0117b51bb31c 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/ccache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.8 2002/12/13 10:56:49 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.9 2003/01/06 20:31:55 agriffis Exp $
+
+*ccache-1.9-r2 (06 Jan 2003)
+
+ 06 Jan 2003; Aron Griffis <agriffis@gentoo.org> ccache-1.9-r2.ebuild :
+ Fix installation of symbolic links by searching PATH for compiler
+ front-ends. Fix einfo commentary to fit in an 80-column terminal.
+ Make this the -r2 release.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-util/ccache/ccache-1.9-r2.ebuild b/dev-util/ccache/ccache-1.9-r2.ebuild
new file mode 100644
index 000000000000..396b1a067460
--- /dev/null
+++ b/dev-util/ccache/ccache-1.9-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-1.9-r2.ebuild,v 1.1 2003/01/06 20:31:55 agriffis Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.6+ installed.
+
+src_compile() {
+ ./configure --prefix=${D}/usr || die
+ make || die
+}
+
+src_install () {
+ exeinto /usr/bin/ccache
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+}
+
+pkg_postinst() {
+ cd /usr/bin/ccache
+
+ # Search the PATH now that gcc doesn't live in /usr/bin
+ einfo "Scanning for compiler front-ends"
+ for a in gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++; do
+ type -ap ${a} && ln -s ccache ${a}
+ done
+
+ if [ ! -d ${ROOT}root/.ccache ]
+ then
+ install -d -m0700 ${ROOT}root/.ccache
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/bin/ccache to your path before /usr/bin. Portage 2.0.6+"
+ einfo "will automatically take advantage of ccache with no additional"
+ einfo "steps. If this is your first install of ccache, type something"
+ einfo "like this to set a maximum cache size of 2GB (or whatever you"
+ einfo "desire):"
+ einfo "# /usr/bin/ccache/ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/digest-ccache-1.9-r2 b/dev-util/ccache/files/digest-ccache-1.9-r2
new file mode 100644
index 000000000000..e27537e953a8
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-1.9-r2
@@ -0,0 +1 @@
+MD5 8e73f607accc13da52934303140d555e ccache-1.9.tar.gz 6258