summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-30 23:09:30 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-30 23:09:30 +0000
commit502d32fbccc968b6ac40844e66640897cac63088 (patch)
treeceacc2cfc1bc824159f8c14f72fee2cdba714a77 /dev-util/cmake
parentBump to atheme-services-7.0.0_alpha8. (diff)
downloadgentoo-2-502d32fbccc968b6ac40844e66640897cac63088.tar.gz
gentoo-2-502d32fbccc968b6ac40844e66640897cac63088.tar.bz2
gentoo-2-502d32fbccc968b6ac40844e66640897cac63088.zip
Add upstream fix for QtCreator and CodeBlocks support, bug 388695
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog8
-rw-r--r--dev-util/cmake/cmake-2.8.6-r3.ebuild171
-rw-r--r--dev-util/cmake/files/cmake-2.8.6-CodeBlocks.patch34
3 files changed, 212 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 5af654a4d334..780f20454ce8 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.174 2011/10/30 10:15:31 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.175 2011/10/30 23:09:30 dilfridge Exp $
+
+*cmake-2.8.6-r3 (30 Oct 2011)
+
+ 30 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +cmake-2.8.6-r3.ebuild, +files/cmake-2.8.6-CodeBlocks.patch:
+ Add upstream fix for QtCreator and CodeBlocks support, bug 388695
30 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -cmake-2.8.5.ebuild,
-cmake-2.8.5-r2.ebuild:
diff --git a/dev-util/cmake/cmake-2.8.6-r3.ebuild b/dev-util/cmake/cmake-2.8.6-r3.ebuild
new file mode 100644
index 000000000000..54cae76bbb97
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.6-r3.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.6-r3.ebuild,v 1.1 2011/10/30 23:09:30 dilfridge Exp $
+
+EAPI=4
+
+CMAKE_REMOVE_MODULES="no"
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils virtualx
+
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 vim-syntax"
+
+DEPEND="
+ >=app-arch/libarchive-2.8.0
+ >=net-misc/curl-7.20.0-r1[ssl]
+ >=dev-libs/expat-2.0.1
+ dev-util/pkgconfig
+ sys-libs/zlib
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4 )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+
+# Fixme:
+# Boost patchset is foobared and should respect eselect / slotting
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindBoost.patch
+ "${FILESDIR}"/${PN}-2.8.6-FindBLAS.patch
+ "${FILESDIR}"/${PN}-2.8.6-FindLAPACK-2.patch
+ "${FILESDIR}"/${PN}-2.8.6-CodeBlocks.patch
+)
+cmake_src_bootstrap() {
+ # Cleanup args to extract only JOBS.
+ # Because bootstrap does not know anything else.
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+cmake_src_test() {
+ # fix OutDir test
+ # this is altered thanks to our eclass
+ sed -i -e 's:#IGNORE ::g' "${S}"/Tests/OutDir/CMakeLists.txt || die
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ # Excluded tests:
+ # BootstrapTest: we actualy bootstrap it every time so why test it.
+ # SimpleCOnly_sdcc: sdcc choke on global cflags so just skip the test
+ # as it was never intended to be used this way.
+ "${CMAKE_BUILD_DIR}"/bin/ctest \
+ -E BootstrapTest SimpleCOnly_sdcc \
+ || die "Tests failed"
+ popd > /dev/null
+}
+
+pkg_setup() {
+ einfo "Fixing java access violations ..."
+ # bug 387227
+ addpredict /proc/self/coredump_filter
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # disable running of cmake in boostrap command
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ cmake_src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ $(cmake-utils_use_build qt4 QtDialog)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use emacs && elisp-compile Docs/cmake-mode.el
+}
+
+src_test() {
+ VIRTUALX_COMMAND="cmake_src_test" virtualmake
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.6-CodeBlocks.patch b/dev-util/cmake/files/cmake-2.8.6-CodeBlocks.patch
new file mode 100644
index 000000000000..8a8fe6f392a8
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.6-CodeBlocks.patch
@@ -0,0 +1,34 @@
+From 240d39a6a4f72fe0e45fc1a1403e0b578d36a142 Mon Sep 17 00:00:00 2001
+From: Clinton Stimpson <clinton@elemtech.com>
+Date: Wed, 5 Oct 2011 10:02:32 -0600
+Subject: [PATCH] Fix XML safety issue with adding preprocessor defines in CodeBlocks project.
+
+---
+ Source/cmExtraCodeBlocksGenerator.cxx | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/Source/cmExtraCodeBlocksGenerator.cxx b/Source/cmExtraCodeBlocksGenerator.cxx
+index 7db91c7..9a0b1ea 100644
+--- a/Source/cmExtraCodeBlocksGenerator.cxx
++++ b/Source/cmExtraCodeBlocksGenerator.cxx
+@@ -19,6 +19,7 @@
+ #include "cmGeneratedFileStream.h"
+ #include "cmTarget.h"
+ #include "cmSystemTools.h"
++#include "cmXMLSafe.h"
+
+ #include <cmsys/SystemTools.hxx>
+
+@@ -585,7 +586,8 @@ void cmExtraCodeBlocksGenerator::AppendTarget(cmGeneratedFileStream& fout,
+ for(std::vector<std::string>::const_iterator di = defs.begin();
+ di != defs.end(); ++di)
+ {
+- fout <<" <Add option=\"-D" << di->c_str() << "\" />\n";
++ cmXMLSafe safedef(di->c_str());
++ fout <<" <Add option=\"-D" << safedef.str() << "\" />\n";
+ }
+ }
+
+--
+1.7.0
+