summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-22 18:00:15 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-22 18:00:15 +0000
commitbd85318ef95f3161f2b17a41778cab0461a1752a (patch)
treebe9aeae490b49b95963d21b2d77d92da653fcdc1 /dev-util/cmake
parentppc stable, bug #209960 (diff)
downloadgentoo-2-bd85318ef95f3161f2b17a41778cab0461a1752a.tar.gz
gentoo-2-bd85318ef95f3161f2b17a41778cab0461a1752a.tar.bz2
gentoo-2-bd85318ef95f3161f2b17a41778cab0461a1752a.zip
Old.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog8
-rw-r--r--dev-util/cmake/cmake-2.0.6-r1.ebuild43
-rw-r--r--dev-util/cmake/cmake-2.4.3.ebuild36
-rw-r--r--dev-util/cmake/cmake-2.4.4.ebuild36
-rw-r--r--dev-util/cmake/cmake-2.4.5.ebuild36
-rw-r--r--dev-util/cmake/cmake-2.4.6-r1.ebuild10
-rw-r--r--dev-util/cmake/cmake-2.4.6.ebuild36
-rw-r--r--dev-util/cmake/cmake-2.4.7-r1.ebuild10
-rw-r--r--dev-util/cmake/cmake-2.4.7-r2.ebuild102
-rw-r--r--dev-util/cmake/cmake-2.4.7.ebuild75
-rw-r--r--dev-util/cmake/cmake-2.4.8_rc12.ebuild103
11 files changed, 15 insertions, 480 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 9e17b3f0d1b5..8369d7b7bede 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.70 2008/02/11 19:41:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.71 2008/02/22 18:00:15 ingmar Exp $
+
+ 22 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -cmake-2.0.6-r1.ebuild,
+ -cmake-2.4.3.ebuild, -cmake-2.4.4.ebuild, -cmake-2.4.5.ebuild,
+ -cmake-2.4.6.ebuild, -cmake-2.4.7.ebuild, -cmake-2.4.7-r2.ebuild,
+ -cmake-2.4.8_rc12.ebuild:
+ Old.
11 Feb 2008; Diego Pettenò <flameeyes@gentoo.org> cmake-2.4.7-r2.ebuild,
cmake-2.4.8_rc12.ebuild, cmake-2.4.8.ebuild:
diff --git a/dev-util/cmake/cmake-2.0.6-r1.ebuild b/dev-util/cmake/cmake-2.0.6-r1.ebuild
deleted file mode 100644
index 408bd047807b..000000000000
--- a/dev-util/cmake/cmake-2.0.6-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.0.6-r1.ebuild,v 1.8 2007/01/04 22:32:38 flameeyes Exp $
-
-inherit flag-o-matic toolchain-funcs eutils
-
-SHORT_PV=2.0
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v${SHORT_PV}/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ia64 mips ppc sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/${P}-rpath-fix.patch
-}
-
-src_compile() {
- strip-flags
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
-}
-
-src_test() {
- einfo "Self tests broken"
- #make test || einfo "note test failure on #17 was expected"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
-}
diff --git a/dev-util/cmake/cmake-2.4.3.ebuild b/dev-util/cmake/cmake-2.4.3.ebuild
deleted file mode 100644
index ca5f7d50a76e..000000000000
--- a/dev-util/cmake/cmake-2.4.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.3.ebuild,v 1.9 2006/12/08 01:09:52 jer Exp $
-
-inherit toolchain-funcs eutils versionator
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-src_compile() {
- cd ${S}
- tc-export CC CXX LD
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
-}
diff --git a/dev-util/cmake/cmake-2.4.4.ebuild b/dev-util/cmake/cmake-2.4.4.ebuild
deleted file mode 100644
index 9cb0b40aeef4..000000000000
--- a/dev-util/cmake/cmake-2.4.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.4.ebuild,v 1.1 2006/11/29 19:24:18 genstef Exp $
-
-inherit toolchain-funcs eutils versionator
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-src_compile() {
- cd ${S}
- tc-export CC CXX LD
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
-}
diff --git a/dev-util/cmake/cmake-2.4.5.ebuild b/dev-util/cmake/cmake-2.4.5.ebuild
deleted file mode 100644
index 2644490672cf..000000000000
--- a/dev-util/cmake/cmake-2.4.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.5.ebuild,v 1.2 2006/12/16 18:34:45 genstef Exp $
-
-inherit toolchain-funcs eutils versionator qt3
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-src_compile() {
- cd ${S}
- tc-export CC CXX LD
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
-}
diff --git a/dev-util/cmake/cmake-2.4.6-r1.ebuild b/dev-util/cmake/cmake-2.4.6-r1.ebuild
index 3b3c63a42d25..47f39316db13 100644
--- a/dev-util/cmake/cmake-2.4.6-r1.ebuild
+++ b/dev-util/cmake/cmake-2.4.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.6-r1.ebuild,v 1.10 2007/10/10 19:27:27 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.6-r1.ebuild,v 1.11 2008/02/22 18:00:15 ingmar Exp $
inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
@@ -23,8 +23,6 @@ SITEFILE="50${PN}-gentoo.el"
VIMFILE="${PN}.vim"
src_compile() {
- cd ${S}
-
if [ "$(gcc-major-version)" -eq "3" ] ; then
append-flags "-fno-stack-protector"
fi
@@ -48,8 +46,8 @@ src_test() {
}
src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
+ make install DESTDIR="${D}" || die "install failed"
+ mv "${D}"usr/share/doc/cmake "${D}"usr/share/doc/${PF}
if use emacs; then
elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
diff --git a/dev-util/cmake/cmake-2.4.6.ebuild b/dev-util/cmake/cmake-2.4.6.ebuild
deleted file mode 100644
index 79c4be4e3b00..000000000000
--- a/dev-util/cmake/cmake-2.4.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.6.ebuild,v 1.1 2007/01/29 01:31:52 flameeyes Exp $
-
-inherit toolchain-funcs eutils versionator qt3
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-src_compile() {
- cd ${S}
- tc-export CC CXX LD
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
-}
diff --git a/dev-util/cmake/cmake-2.4.7-r1.ebuild b/dev-util/cmake/cmake-2.4.7-r1.ebuild
index d610fffbcb24..5a554fec45e1 100644
--- a/dev-util/cmake/cmake-2.4.7-r1.ebuild
+++ b/dev-util/cmake/cmake-2.4.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.7-r1.ebuild,v 1.3 2007/10/10 19:27:27 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.7-r1.ebuild,v 1.4 2008/02/22 18:00:15 ingmar Exp $
inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
@@ -31,8 +31,6 @@ src_unpack() {
}
src_compile() {
- cd ${S}
-
if [ "$(gcc-major-version)" -eq "3" ] ; then
append-flags "-fno-stack-protector"
fi
@@ -56,8 +54,8 @@ src_test() {
}
src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
+ make install DESTDIR="${D}" || die "install failed"
+ mv "${D}"usr/share/doc/cmake "${D}"usr/share/doc/${PF}
if use emacs; then
elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
diff --git a/dev-util/cmake/cmake-2.4.7-r2.ebuild b/dev-util/cmake/cmake-2.4.7-r2.ebuild
deleted file mode 100644
index 98af0de2dff5..000000000000
--- a/dev-util/cmake/cmake-2.4.7-r2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.7-r2.ebuild,v 1.6 2008/02/11 19:41:38 flameeyes Exp $
-
-inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs vim-syntax"
-
-DEPEND=">=net-misc/curl-7.16.4
- >=dev-libs/expat-2.0.1
- >=dev-libs/libxml2-2.6.28
- >=dev-libs/xmlrpc-c-1.06.03
- emacs? ( virtual/emacs )
- vim-syntax? ( || (
- app-editors/vim
- app-editors/gvim ) )"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-VIMFILE="${PN}.vim"
-
-pkg_setup() {
- if ! built_with_use dev-libs/xmlrpc-c libwww && ! built_with_use dev-libs/xmlrpc-c curl ; then
- echo
- eerror "${PN} requires dev-libs/xmlrpc-c to be built with either the 'libwww' or"
- eerror "the 'curl' USE flag or both enabled."
- eerror "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
- echo
- die "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Upstream patch to make sure KDE4 is found. cf. bug 191412.
- epatch "${FILESDIR}/${P}-findkde4.patch"
-
- # Upstream's version is broken. Reported in upstream bugs 3498, 3637, 4145.
- # Fixed version kindly provided on 4145 by Axel Roebel.
- cp "${FILESDIR}/FindSWIG.cmake" "${S}/Modules/"
-}
-
-src_compile() {
- if [ "$(gcc-major-version)" -eq "3" ] ; then
- append-flags "-fno-stack-protector"
- fi
-
- tc-export CC CXX LD
-
- ./bootstrap \
- --system-libs \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
- if use emacs; then
- elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
- fi
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- mv "${D}usr/share/doc/cmake" "${D}usr/share/doc/${PF}"
- if use emacs; then
- elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/Docs/cmake-syntax.vim
-
- insinto /usr/share/vim/vimfiles/indent
- doins "${S}"/Docs/cmake-indent.vim
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}/${VIMFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/cmake/cmake-2.4.7.ebuild b/dev-util/cmake/cmake-2.4.7.ebuild
deleted file mode 100644
index ee42b2138b58..000000000000
--- a/dev-util/cmake/cmake-2.4.7.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.7.ebuild,v 1.4 2007/10/10 19:27:27 phreak Exp $
-
-inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs vim-syntax"
-
-DEPEND="emacs? ( virtual/emacs )
- vim-syntax? ( || (
- app-editors/vim
- app-editors/gvim ) )"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-VIMFILE="${PN}.vim"
-
-src_compile() {
- cd ${S}
-
- if [ "$(gcc-major-version)" -eq "3" ] ; then
- append-flags "-fno-stack-protector"
- fi
-
- tc-export CC CXX LD
- ./bootstrap \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
- if use emacs; then
- elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
- fi
-}
-
-src_test() {
- einfo "Self tests broken"
- make test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "install failed"
- mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
- if use emacs; then
- elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/Docs/cmake-syntax.vim
-
- insinto /usr/share/vim/vimfiles/indent
- doins "${S}"/Docs/cmake-indent.vim
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}/${VIMFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/cmake/cmake-2.4.8_rc12.ebuild b/dev-util/cmake/cmake-2.4.8_rc12.ebuild
deleted file mode 100644
index fb42caaeb794..000000000000
--- a/dev-util/cmake/cmake-2.4.8_rc12.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.8_rc12.ebuild,v 1.2 2008/02/11 19:41:38 flameeyes Exp $
-
-inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
-
-MY_PV="${PV/rc/RC-}"
-MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="CMake"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs vim-syntax"
-
-DEPEND=">=net-misc/curl-7.16.4
- >=dev-libs/expat-2.0.1
- >=dev-libs/libxml2-2.6.28
- >=dev-libs/xmlrpc-c-1.06.09
- emacs? ( virtual/emacs )
- vim-syntax? ( || (
- app-editors/vim
- app-editors/gvim ) )"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-VIMFILE="${PN}.vim"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! built_with_use dev-libs/xmlrpc-c libwww && ! built_with_use dev-libs/xmlrpc-c curl ; then
- echo
- eerror "${PN} requires dev-libs/xmlrpc-c to be built with either the 'libwww' or"
- eerror "the 'curl' USE flag or both enabled."
- eerror "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
- echo
- die "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Upstream's version is broken. Reported in upstream bugs 3498, 3637, 4145.
- # Fixed version kindly provided on 4145 by Axel Roebel.
- cp "${FILESDIR}/FindSWIG.cmake" "${S}/Modules/"
-}
-
-src_compile() {
- if [[ "$(gcc-major-version)" -eq "3" ]] ; then
- append-flags "-fno-stack-protector"
- fi
-
- tc-export CC CXX LD
-
- ./bootstrap \
- --system-libs \
- --prefix=/usr \
- --docdir=/share/doc/${PN} \
- --datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
- emake || die
- if use emacs; then
- elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
- fi
-}
-
-src_test() {
- emake test || \
- einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- mv "${D}usr/share/doc/cmake" "${D}usr/share/doc/${PF}"
- if use emacs; then
- elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/Docs/cmake-syntax.vim
-
- insinto /usr/share/vim/vimfiles/indent
- doins "${S}"/Docs/cmake-indent.vim
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}/${VIMFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}