summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-23 04:49:47 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-23 04:49:47 +0000
commit0e955c555b910f726f41b2083428fa593377a8c2 (patch)
treeeb5ac69011050a91a41da78f997afe05bfad5867 /dev-util/coccigrep
parentDrop useless doc USE flag (bug #447670). Respect USE=-introspection. (diff)
downloadgentoo-2-0e955c555b910f726f41b2083428fa593377a8c2.tar.gz
gentoo-2-0e955c555b910f726f41b2083428fa593377a8c2.tar.bz2
gentoo-2-0e955c555b910f726f41b2083428fa593377a8c2.zip
Version bump. Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/coccigrep')
-rw-r--r--dev-util/coccigrep/ChangeLog7
-rw-r--r--dev-util/coccigrep/coccigrep-1.12.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-util/coccigrep/ChangeLog b/dev-util/coccigrep/ChangeLog
index 613fc461ce4f..d453df599281 100644
--- a/dev-util/coccigrep/ChangeLog
+++ b/dev-util/coccigrep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/coccigrep
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccigrep/ChangeLog,v 1.13 2012/12/13 21:11:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccigrep/ChangeLog,v 1.14 2012/12/23 04:49:47 radhermit Exp $
+
+*coccigrep-1.12 (23 Dec 2012)
+
+ 23 Dec 2012; Tim Harder <radhermit@gentoo.org> +coccigrep-1.12.ebuild:
+ Version bump. Migrate to distutils-r1.
13 Dec 2012; Tim Harder <radhermit@gentoo.org> -coccigrep-1.8.ebuild,
-coccigrep-1.9.ebuild:
diff --git a/dev-util/coccigrep/coccigrep-1.12.ebuild b/dev-util/coccigrep/coccigrep-1.12.ebuild
new file mode 100644
index 000000000000..8cc7b5a56717
--- /dev/null
+++ b/dev-util/coccigrep/coccigrep-1.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccigrep/coccigrep-1.12.ebuild,v 1.1 2012/12/23 04:49:47 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 elisp-common vcs-snapshot
+
+DESCRIPTION="A semantic grep for the C language"
+HOMEPAGE="http://home.regit.org/software/coccigrep/"
+SRC_URI="https://github.com/regit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs vim"
+
+RDEPEND="dev-util/coccinelle[python]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="doc? ( dev-python/sphinx )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+python_compile_all() {
+ use doc && emake -C doc html
+
+ if use emacs ; then
+ elisp-compile editors/*.el || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+
+ use doc && dohtml -r doc/_build/html/*
+
+ if use emacs ; then
+ elisp-install ${PN} editors/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ if use vim ; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins editors/cocci-grep.vim
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ einfo "Syntax highlighting is supported through dev-python/pygments."
+ einfo "Install it if you want colorized output formats."
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}