summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-05 14:35:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-05 14:35:09 +0000
commit6cf713425aef7c2fb32c3d6540da1f799fbbf201 (patch)
tree157d54d4a4e6091c79929419cc283f53aff42196 /dev-util/coccinelle
parentDistribute help images wrt offlinehelp. Thanks to geki and his work on this. (diff)
downloadgentoo-2-6cf713425aef7c2fb32c3d6540da1f799fbbf201.tar.gz
gentoo-2-6cf713425aef7c2fb32c3d6540da1f799fbbf201.tar.bz2
gentoo-2-6cf713425aef7c2fb32c3d6540da1f799fbbf201.zip
remove stray patches too
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/ChangeLog7
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch19
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch30
3 files changed, 6 insertions, 50 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index 3aa1aff83acd..d25b05882c05 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/coccinelle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.17 2012/05/05 14:30:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.18 2012/05/05 14:35:08 aballier Exp $
+
+ 05 May 2012; Alexis Ballier <aballier@gentoo.org>
+ -files/coccinelle-1.0.0_rc7-pcre.patch,
+ -files/coccinelle-1.0.0_rc7-pcre-linking.patch:
+ remove stray patches too
05 May 2012; Alexis Ballier <aballier@gentoo.org>
-coccinelle-1.0.0_rc7.ebuild, -coccinelle-1.0.0_rc10.ebuild:
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch
deleted file mode 100644
index 271dcf9ceedc..000000000000
--- a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre-linking.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- coccinelle-1.0.0-rc7/Makefile.orig
-+++ coccinelle-1.0.0-rc7/Makefile
-@@ -225,13 +225,13 @@
- $(OPTOBJS):$(LIBS:.cma=.cmxa)
-
- $(EXEC): $(LIBS) $(OBJS)
-- $(OCAMLC) $(BYTECODE_STATIC) -o $@ $(SYSLIBS) $(SEXPLIB) $^
-+ $(OCAMLC) $(BYTECODE_STATIC) -o $@ $(SYSLIBS) $(SEXPLIB) $^ $(PCRELIB)
-
- $(EXEC).opt: $(LIBS:.cma=.cmxa) $(OPTOBJS)
-- $(OCAMLOPT) $(STATIC) -o $@ $(SYSLIBS:.cma=.cmxa) $(OPTSEXPLIB) $(OPTLIBFLAGS) $^
-+ $(OCAMLOPT) $(STATIC) -o $@ $(SYSLIBS:.cma=.cmxa) $(OPTSEXPLIB) $(OPTLIBFLAGS) $^ $(PCRELIB:.cma=.cmxa)
-
- $(EXEC).top: $(LIBS) $(OBJS)
-- $(OCAMLMKTOP) -custom -o $@ $(SYSLIBS) $(SEXPLIB) $^
-+ $(OCAMLMKTOP) -custom -o $@ $(SYSLIBS) $(SEXPLIB) $^ $(PCRELIB)
-
- clean::
- rm -f $(TARGET) $(TARGET).opt $(TARGET).top
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch
deleted file mode 100644
index d9b5c9e3f427..000000000000
--- a/dev-util/coccinelle/files/coccinelle-1.0.0_rc7-pcre.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-http://www.mail-archive.com/cocci@diku.dk/msg01695.html
-
-diff --git a/parsing_cocci/function_prototypes.ml b/parsing_cocci/function_prototypes.ml
-index 2f2225a..257e0ca 100644
---- a/parsing_cocci/function_prototypes.ml
-+++ b/parsing_cocci/function_prototypes.ml
-@@ -153,18 +153,19 @@ and strip =
- ref [],-1) in
-
- (* need a case for everything that has an unvisited component and can be in
-- a function prototype *)
-+ a function prototype. Also get rid of constraints because pcre
-+ constraints cannot be compared. *)
-
- let ident r k e =
- donothing r k
- (Ast0.rewrap e
- (match Ast0.unwrap e with
- Ast0.MetaId(nm,constraints,seed,pure) ->
-- Ast0.MetaId(nm,constraints,seed,Ast0.Pure)
-+ Ast0.MetaId(nm,Ast.IdNoConstraint,seed,Ast0.Pure)
- | Ast0.MetaFunc(nm,constraints,pure) ->
-- Ast0.MetaFunc(nm,constraints,Ast0.Pure)
-+ Ast0.MetaFunc(nm,Ast.IdNoConstraint,Ast0.Pure)
- | Ast0.MetaLocalFunc(nm,constraints,pure) ->
-- Ast0.MetaLocalFunc(nm,constraints,Ast0.Pure)
-+ Ast0.MetaLocalFunc(nm,Ast.IdNoConstraint,Ast0.Pure)
- | e -> e)) in
-
- let typeC r k e =