summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-03-20 15:52:07 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-03-20 15:52:07 +0000
commit6bb69fe438db00a0f079ce443a9d1a1ad101582b (patch)
tree707afac0ec9cff74dbbc3600c6b14d135733aff7 /dev-util/comparator
parentAdd -r1 with a patch fixing paludis_command(). (diff)
downloadgentoo-2-6bb69fe438db00a0f079ce443a9d1a1ad101582b.tar.gz
gentoo-2-6bb69fe438db00a0f079ce443a9d1a1ad101582b.tar.bz2
gentoo-2-6bb69fe438db00a0f079ce443a9d1a1ad101582b.zip
Version bump, fix quoting. einstall->emake install
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/comparator')
-rw-r--r--dev-util/comparator/ChangeLog9
-rw-r--r--dev-util/comparator/comparator-2.5.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/comparator/ChangeLog b/dev-util/comparator/ChangeLog
index 215f8feedbb2..ab28ec9c580a 100644
--- a/dev-util/comparator/ChangeLog
+++ b/dev-util/comparator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/comparator
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/ChangeLog,v 1.9 2007/02/09 03:03:45 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/ChangeLog,v 1.10 2008/03/20 15:52:07 rbu Exp $
+
+*comparator-2.5 (20 Mar 2008)
+
+ 20 Mar 2008; Robert Buchholz <rbu@gentoo.org> +comparator-2.5.ebuild:
+ Version bump, fix quoting. einstall->emake install
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-util/comparator/comparator-2.5.ebuild b/dev-util/comparator/comparator-2.5.ebuild
new file mode 100644
index 000000000000..0b0890472901
--- /dev/null
+++ b/dev-util/comparator/comparator-2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/comparator-2.5.ebuild,v 1.1 2008/03/20 15:52:07 rbu Exp $
+
+inherit distutils toolchain-funcs
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+#DEPEND='' inherit handles this
+DEPEND="${DEPEND} app-text/xmlto"
+RDEPEND="${RDEPEND}" #becase I don't want xmlto in here
+
+src_unpack() {
+ unpack ${A}
+ # we will do this ourselves
+ sed -e '/python setup.py install/d' -i "${S}"/Makefile
+ # Fix the Makefile to accept our CFLAGS
+ sed -e "s/CFLAGS = -O3/CFLAGS = ${CFLAGS}/" -i "${S}"/Makefile
+}
+
+src_compile() {
+ distutils_src_install
+ emake CC="$(tc-getCC)" || die "emake failed"
+ emake comparator.html scf-standard.html || die "emake docs failed"
+}
+
+src_install() {
+ distutils_src_install
+ emake ROOT="${D}" install || die "einstall failed"
+ dohtml *.html
+}