summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-11-05 17:53:47 +0000
committerMichael Weber <xmw@gentoo.org>2012-11-05 17:53:47 +0000
commit764ca4934546fb927fc8963e02139e7b157e53d3 (patch)
treeb31ef4d5ddfdfbdae7c1f71624981a99c7940bbc /dev-util/cppcheck
parentVersion bump. (diff)
downloadgentoo-2-764ca4934546fb927fc8963e02139e7b157e53d3.tar.gz
gentoo-2-764ca4934546fb927fc8963e02139e7b157e53d3.tar.bz2
gentoo-2-764ca4934546fb927fc8963e02139e7b157e53d3.zip
Version bump, remove qt-assistant dep (bug 441822, thanks Nikoli)
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog8
-rw-r--r--dev-util/cppcheck/cppcheck-1.56.ebuild5
-rw-r--r--dev-util/cppcheck/cppcheck-1.57.ebuild80
3 files changed, 89 insertions, 4 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 69a90030b260..510e8229f6f1 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.34 2012/11/03 17:32:27 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.35 2012/11/05 17:53:47 xmw Exp $
+
+*cppcheck-1.57 (05 Nov 2012)
+
+ 05 Nov 2012; Michael Weber <xmw@gentoo.org> cppcheck-1.56.ebuild,
+ +cppcheck-1.57.ebuild:
+ Version bump, remove qt-assistant dep (bug 441822, thanks Nikoli)
03 Nov 2012; Michael Weber <xmw@gentoo.org> -cppcheck-1.53.ebuild,
-cppcheck-1.54.ebuild, -cppcheck-1.55.ebuild:
diff --git a/dev-util/cppcheck/cppcheck-1.56.ebuild b/dev-util/cppcheck/cppcheck-1.56.ebuild
index 704229a3a5ca..b2bb320c4a35 100644
--- a/dev-util/cppcheck/cppcheck-1.56.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.56.ebuild,v 1.1 2012/09/06 06:58:58 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.56.ebuild,v 1.2 2012/11/05 17:53:47 xmw Exp $
EAPI="3"
PYTHON_DEPEND="htmlreport? 2"
@@ -17,8 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="htmlreport qt4"
DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
+ qt4? ( x11-libs/qt-gui:4 )"
RDEPEND="${DEPEND}"
DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
diff --git a/dev-util/cppcheck/cppcheck-1.57.ebuild b/dev-util/cppcheck/cppcheck-1.57.ebuild
new file mode 100644
index 000000000000..2cc2dfcd3324
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.57.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.57.ebuild,v 1.1 2012/11/05 17:53:47 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+ #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
+ #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
+ # democlient.cpp -I../lib democlient.cpp
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+ #dobin ${PN}-democlient.cgi
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}