summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-09-06 06:58:58 +0000
committerMichael Weber <xmw@gentoo.org>2012-09-06 06:58:58 +0000
commit779fa3f1991a9e6d6e1afec00a14f85062ab28eb (patch)
tree162567e19b325e03c0a32ef6e7fa0079af0dcaef /dev-util/cppcheck
parentold, none of these build anymore due to recent bumps in revdeps (diff)
downloadgentoo-2-779fa3f1991a9e6d6e1afec00a14f85062ab28eb.tar.gz
gentoo-2-779fa3f1991a9e6d6e1afec00a14f85062ab28eb.tar.bz2
gentoo-2-779fa3f1991a9e6d6e1afec00a14f85062ab28eb.zip
Version bump, democlient does not compile
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog7
-rw-r--r--dev-util/cppcheck/cppcheck-1.56.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 2ebd1b6c4955..40c3f7ec4c5c 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.32 2012/07/05 12:44:26 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.33 2012/09/06 06:58:58 xmw Exp $
+
+*cppcheck-1.56 (06 Sep 2012)
+
+ 06 Sep 2012; Michael Weber <xmw@gentoo.org> +cppcheck-1.56.ebuild:
+ Version bump, democlient does not compile
*cppcheck-1.55 (05 Jul 2012)
diff --git a/dev-util/cppcheck/cppcheck-1.56.ebuild b/dev-util/cppcheck/cppcheck-1.56.ebuild
new file mode 100644
index 000000000000..704229a3a5ca
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.56.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.56.ebuild,v 1.1 2012/09/06 06:58:58 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="htmlreport? 2"
+
+inherit distutils eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+DEPEND="htmlreport? ( dev-python/pygments )
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-assistant:4 )"
+RDEPEND="${DEPEND}"
+
+DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
+
+pkg_setup() {
+ if use htmlreport ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use htmlreport ; then
+ pushd htmlreport
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ use htmlreport && distutils_src_compile
+ #https://sourceforge.net/apps/trac/cppcheck/ticket/4149
+ #$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -o ${PN}-democlient.cgi \
+ # democlient.cpp -I../lib democlient.cpp
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc readme.txt || die
+ if use qt4 ; then
+ dobin gui/${PN}-gui || die
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
+ fi
+ use htmlreport && distutils_src_install
+ #dobin ${PN}-democlient.cgi
+}
+
+pkg_postinst() {
+ use htmlreport && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use htmlreport && distutils_pkg_postrm
+}