summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2004-06-09 17:56:54 +0000
committerRainer Groesslinger <scandium@gentoo.org>2004-06-09 17:56:54 +0000
commitc2bafa8937ec4e74d6f88f567b0444f67a9220c8 (patch)
tree6457abc17ddca0ebe12b85fb36daeb531cb8911d /dev-util/cvs/cvs-1.11.17.ebuild
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-c2bafa8937ec4e74d6f88f567b0444f67a9220c8.tar.gz
gentoo-2-c2bafa8937ec4e74d6f88f567b0444f67a9220c8.tar.bz2
gentoo-2-c2bafa8937ec4e74d6f88f567b0444f67a9220c8.zip
new version, security update (bug #53408)
Diffstat (limited to 'dev-util/cvs/cvs-1.11.17.ebuild')
-rw-r--r--dev-util/cvs/cvs-1.11.17.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/cvs/cvs-1.11.17.ebuild b/dev-util/cvs/cvs-1.11.17.ebuild
new file mode 100644
index 000000000000..37b2105ad475
--- /dev/null
+++ b/dev-util/cvs/cvs-1.11.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.11.17.ebuild,v 1.1 2004/06/09 17:56:52 scandium Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.cvshome.org/"
+
+# scandium@gentoo.org (9th June 2004)
+# Recently, upstream changed the directory structure for the files.
+# The directory numbers in the middle differ for every release/file, so
+# unfortunatly they have to be corrected with every new release.
+SRC_URI="http://ccvs.cvshome.org/files/documents/19/191/${P}.tar.bz2
+ doc? ( http://ccvs.cvshome.org/files/documents/19/199/cederqvist-${PV}.html.tar.bz2
+ http://ccvs.cvshome.org/files/documents/19/197/cederqvist-${PV}.pdf
+ http://ccvs.cvshome.org/files/documents/19/196/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+
+IUSE="doc emacs"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ use alpha && append-flags -fPIC
+
+ econf --with-tmpdir=/tmp || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+}