summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-08-02 05:31:16 +0000
committerBrian Harring <ferringb@gentoo.org>2011-08-02 05:31:16 +0000
commit0b41c35694dad6ed012f42002f62b1020a31b757 (patch)
treedf343f7ff3b22f6e203fcf2b055558747c965415 /dev-util/diffball
parentStable for HPPA (bug #375579). (diff)
downloadgentoo-2-0b41c35694dad6ed012f42002f62b1020a31b757.tar.gz
gentoo-2-0b41c35694dad6ed012f42002f62b1020a31b757.tar.bz2
gentoo-2-0b41c35694dad6ed012f42002f62b1020a31b757.zip
bump diffball to 1.0.1 w/ xz support
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/diffball')
-rw-r--r--dev-util/diffball/ChangeLog7
-rw-r--r--dev-util/diffball/diffball-1.0.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-util/diffball/ChangeLog b/dev-util/diffball/ChangeLog
index accbf20a8848..d76b0b4657f8 100644
--- a/dev-util/diffball/ChangeLog
+++ b/dev-util/diffball/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/diffball
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diffball/ChangeLog,v 1.36 2011/07/25 09:47:55 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffball/ChangeLog,v 1.37 2011/08/02 05:31:16 ferringb Exp $
+
+*diffball-1.0.1 (02 Aug 2011)
+
+ 02 Aug 2011; Brian Harring <ferringb@gentoo.org> +diffball-1.0.1.ebuild:
+ Add diffball 1.0.1 with xz support
25 Jul 2011; Naohiro Aota <naota@gentoo.org> diffball-1.0.ebuild:
Add keyword ~x86-fbsd
diff --git a/dev-util/diffball/diffball-1.0.1.ebuild b/dev-util/diffball/diffball-1.0.1.ebuild
new file mode 100644
index 000000000000..fd1d80bde8b0
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffball/diffball-1.0.1.ebuild,v 1.1 2011/08/02 05:31:16 ferringb Exp $
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="http://diffball.googlecode.com/"
+SRC_URI="http://diffball.googlecode.com/files/${PN}-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+src_compile() {
+ econf $(use_enable debug asserts)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}