summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-05-25 07:14:18 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-05-25 07:14:18 +0000
commit19a69a78925756a65c003f7335e6cadd660dd100 (patch)
tree8db0af9bf0d931bdcaeb3259f446b010d29651d9 /dev-util/eric/eric-3.4.2.ebuild
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-19a69a78925756a65c003f7335e6cadd660dd100.tar.gz
gentoo-2-19a69a78925756a65c003f7335e6cadd660dd100.tar.bz2
gentoo-2-19a69a78925756a65c003f7335e6cadd660dd100.zip
Version bump.
Diffstat (limited to 'dev-util/eric/eric-3.4.2.ebuild')
-rw-r--r--dev-util/eric/eric-3.4.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/eric/eric-3.4.2.ebuild b/dev-util/eric/eric-3.4.2.ebuild
new file mode 100644
index 000000000000..e76cd7f9ff8a
--- /dev/null
+++ b/dev-util/eric/eric-3.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.4.2.ebuild,v 1.1 2004/05/25 07:14:18 kloeri Exp $
+
+IUSE="idl"
+
+inherit python eutils
+
+DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
+SRC_URI="http://www.die-offenbachs.de/detlev/files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+python_version
+IDIR="/usr/lib/python${PYVER}/site-packages/eric3/"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.1
+ >=dev-python/qscintilla-1.54
+ >=dev-lang/python-2.2.3
+ >=dev-python/sip-3.8
+ >=dev-python/PyQt-3.8.1"
+
+RDEPEND="idl? ( !ppc? ( >=net-misc/omniORB-4.0.3 ) )"
+
+src_install() {
+ python install.py \
+ -b /usr/bin \
+ -i ${D} \
+ -c
+ dodir "${IDIR}Tools"
+ cp ${S}/patch_modpython.py ${D}/${IDIR}Tools
+ dodoc HISTORY LICENSE.GPL THANKS eric/README*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "If you want to use eric3 with mod_python, have a look at"
+ einfo "\"${IDIR}Tools/patch_modpython.py\"."
+ einfo ""
+}