summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-03-11 15:47:52 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-03-11 15:47:52 +0000
commite02d8310fec0276ab1ede10923a524b3dc8e2bcd (patch)
treee2cf6c83c7d3924c55355fb0e3eb9bc859f3cf57 /dev-util/febootstrap
parentFix building against xorg-server-1.14, bug #461236. (diff)
downloadgentoo-2-e02d8310fec0276ab1ede10923a524b3dc8e2bcd.tar.gz
gentoo-2-e02d8310fec0276ab1ede10923a524b3dc8e2bcd.tar.bz2
gentoo-2-e02d8310fec0276ab1ede10923a524b3dc8e2bcd.zip
Fix compilation with glibc-2.16, bug #438002.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-util/febootstrap')
-rw-r--r--dev-util/febootstrap/ChangeLog9
-rw-r--r--dev-util/febootstrap/febootstrap-2.11.ebuild14
-rw-r--r--dev-util/febootstrap/files/remove_all-static.patch12
3 files changed, 29 insertions, 6 deletions
diff --git a/dev-util/febootstrap/ChangeLog b/dev-util/febootstrap/ChangeLog
index 82433f6a2746..5f6cdf740c6b 100644
--- a/dev-util/febootstrap/ChangeLog
+++ b/dev-util/febootstrap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/febootstrap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/febootstrap/ChangeLog,v 1.3 2012/06/14 17:09:49 maksbotan Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/febootstrap/ChangeLog,v 1.4 2013/03/11 15:47:51 maksbotan Exp $
+
+ 11 Mar 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/remove_all-static.patch, febootstrap-2.11.ebuild:
+ Fix compilation with glibc-2.16, bug #438002.
*febootstrap-2.11 (14 Jun 2012)
@@ -15,4 +19,3 @@
10 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +febootstrap-3.9.ebuild,
+metadata.xml:
Add dev-util/febootstrap-3.9, thanks to slepnoga. Bug 309805
-
diff --git a/dev-util/febootstrap/febootstrap-2.11.ebuild b/dev-util/febootstrap/febootstrap-2.11.ebuild
index 5f3b8d6c75a9..d0d97bf357f8 100644
--- a/dev-util/febootstrap/febootstrap-2.11.ebuild
+++ b/dev-util/febootstrap/febootstrap-2.11.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/febootstrap/febootstrap-2.11.ebuild,v 1.1 2012/06/14 17:09:49 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/febootstrap/febootstrap-2.11.ebuild,v 1.2 2013/03/11 15:47:51 maksbotan Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Fedora bootstrap scripts"
HOMEPAGE="http://people.redhat.com/~rjones/febootstrap/"
@@ -24,6 +24,14 @@ DEPEND=">=sys-apps/fakeroot-1.11
RDEPEND="${DEPEND}"
QA_EXECSTACK="usr/bin/febootstrap-supermin-helper"
+src_prepare() {
+ # https://lists.gnu.org/archive/html/grub-devel/2012-07/msg00051.html
+ sed -i -e '/gets is a security/d' lib/stdio.in.h
+ epatch "${FILESDIR}"/remove_all-static.patch
+
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc TODO README examples/*.sh || die
diff --git a/dev-util/febootstrap/files/remove_all-static.patch b/dev-util/febootstrap/files/remove_all-static.patch
new file mode 100644
index 000000000000..4f0f16e79b92
--- /dev/null
+++ b/dev-util/febootstrap/files/remove_all-static.patch
@@ -0,0 +1,12 @@
+diff --git a/helper/Makefile.am b/helper/Makefile.am
+--- a/helper/Makefile.am
++++ b/helper/Makefile.am
+@@ -40,7 +40,7 @@
+ noinst_PROGRAMS = init
+ init_SOURCES = init.c
+ init_CFLAGS = -static
+-init_LDFLAGS = -all-static
++init_LDFLAGS = -static
+
+ # http://www.doof.me.uk/2010/05/07/cute-objcopy-hack/
+ ELF_DEFAULT_ARCH = $(shell $(srcdir)/elf-default-arch | gawk '{ print $$1 }')