summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-26 07:49:54 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-26 07:49:54 +0000
commit0350a3e2489c2532c545cb1af31236ec644e88cb (patch)
tree9e64d78b3266982dffe16c06d9f939a1f510ff39 /dev-util/fix-la-relink-command
parentBump text to 0.11.2.1 (diff)
downloadgentoo-2-0350a3e2489c2532c545cb1af31236ec644e88cb.tar.gz
gentoo-2-0350a3e2489c2532c545cb1af31236ec644e88cb.tar.bz2
gentoo-2-0350a3e2489c2532c545cb1af31236ec644e88cb.zip
Add a last-resort hack for fixing up relink_command in .la files to prevent libraries that are being built from linking to older versions of themselves installed in the filesystem. Needed e.g. for evolution-data-server and libxml2. Derived from a script used in the evolution-data-server ebuild, and therefore keyworded on arches where evolution-data-server itself is keyworded.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/fix-la-relink-command')
-rw-r--r--dev-util/fix-la-relink-command/ChangeLog15
-rw-r--r--dev-util/fix-la-relink-command/fix-la-relink-command-0.1.ebuild29
-rw-r--r--dev-util/fix-la-relink-command/metadata.xml9
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/fix-la-relink-command/ChangeLog b/dev-util/fix-la-relink-command/ChangeLog
new file mode 100644
index 000000000000..b9b8b932a962
--- /dev/null
+++ b/dev-util/fix-la-relink-command/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-util/fix-la-relink-command
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fix-la-relink-command/ChangeLog,v 1.1 2012/05/26 07:49:54 tetromino Exp $
+
+*fix-la-relink-command-0.1 (26 May 2012)
+
+ 26 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +fix-la-relink-command-0.1.ebuild, +metadata.xml:
+ Add a last-resort hack for fixing up relink_command in .la files to prevent
+ libraries that are being built from linking to older versions of themselves
+ installed in the filesystem. Needed e.g. for evolution-data-server and
+ libxml2. Derived from a script used in the evolution-data-server ebuild, and
+ therefore keyworded on arches where evolution-data-server itself is
+ keyworded.
+
diff --git a/dev-util/fix-la-relink-command/fix-la-relink-command-0.1.ebuild b/dev-util/fix-la-relink-command/fix-la-relink-command-0.1.ebuild
new file mode 100644
index 000000000000..31993d2d04fb
--- /dev/null
+++ b/dev-util/fix-la-relink-command/fix-la-relink-command-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fix-la-relink-command/fix-la-relink-command-0.1.ebuild,v 1.1 2012/05/26 07:49:54 tetromino Exp $
+
+EAPI="4"
+
+DESCRIPTION="Helps prevent .la files from relinking to libraries outside a build tree"
+HOMEPAGE="http://dev.gentoo.org/~tetromino/distfiles/${PN}"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_compile() {
+ PERLDOC="-onroff -d${PN}.1" ./${PN} --man || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc NEWS
+}
diff --git a/dev-util/fix-la-relink-command/metadata.xml b/dev-util/fix-la-relink-command/metadata.xml
new file mode 100644
index 000000000000..7aa4c63325e2
--- /dev/null
+++ b/dev-util/fix-la-relink-command/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tetromino@gentoo.org</email>
+<name>Alexandre Rostovtsev</name>
+</maintainer>
+<herd>gnome</herd>
+</pkgmetadata>