summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-03-08 21:18:33 +0000
committerMarius Mauch <genone@gentoo.org>2004-03-08 21:18:33 +0000
commit04a0afc9c3e2266606532c3091e10a99783dec1d (patch)
tree2c7dea7dae2295c81278c7608bb43015ddd2bd9b /dev-util/gambas
parentVersion bumped (Manifest recommit) (diff)
downloadgentoo-2-04a0afc9c3e2266606532c3091e10a99783dec1d.tar.gz
gentoo-2-04a0afc9c3e2266606532c3091e10a99783dec1d.tar.bz2
gentoo-2-04a0afc9c3e2266606532c3091e10a99783dec1d.zip
move /usr/lib/info to /usr/lib/gambas/info
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog5
-rw-r--r--dev-util/gambas/files/info-location-0.90.patch22
-rw-r--r--dev-util/gambas/gambas-0.90-r1.ebuild5
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 59e1cd0a5036..a0b5fce4c511 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.7 2004/03/08 19:42:19 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.8 2004/03/08 21:18:33 genone Exp $
+
+ 08 Mar 2004; Marius Mauch <genone@gentoo.org> gambas-0.90-r1.ebuild:
+ move /usr/lib/info/* to /usr/lib/gambas/info/
*gambas-0.90-r1 (08 Mar 2004)
diff --git a/dev-util/gambas/files/info-location-0.90.patch b/dev-util/gambas/files/info-location-0.90.patch
new file mode 100644
index 000000000000..5f5e49dbb816
--- /dev/null
+++ b/dev-util/gambas/files/info-location-0.90.patch
@@ -0,0 +1,22 @@
+--- src/comp/gbi.c.orig 2004-03-08 21:46:41.263561816 +0100
++++ src/comp/gbi.c 2004-02-07 18:33:10.000000000 +0100
+@@ -633,7 +605,7 @@
+ if (strcmp(FILE_get_ext(name), ".component"))
+ continue;
+
+- path = STR_copy(FILE_set_ext(FILE_cat(_lib_path, "info", &name[4], NULL), ".info"));
++ path = STR_copy(FILE_set_ext(FILE_cat(_lib_path, "gambas/info", &name[4], NULL), ".info"));
+ name = STR_copy(FILE_get_basename(&name[4]));
+
+ out = fopen(path, "w");
+--- app/gambas/CComponent.class.orig 2004-03-08 22:06:19.147496240 +0100
++++ app/gambas/CComponent.class 2004-03-08 22:00:17.712442720 +0100
+@@ -124,7 +124,7 @@
+ All[sLig].Load
+ NEXT
+
+- sPath = Component.Path &/ "info" &/ Key & ".info"
++ sPath = Component.Path &/ "gambas/info" &/ Key & ".info"
+ IF NOT Exist(sPath) THEN
+ PRINT "Warning: cannot find "; sPath
+ RETURN
diff --git a/dev-util/gambas/gambas-0.90-r1.ebuild b/dev-util/gambas/gambas-0.90-r1.ebuild
index cfdbfac57c4e..0f3a77b067d9 100644
--- a/dev-util/gambas/gambas-0.90-r1.ebuild
+++ b/dev-util/gambas/gambas-0.90-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90-r1.ebuild,v 1.1 2004/03/08 19:42:19 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90-r1.ebuild,v 1.2 2004/03/08 21:18:33 genone Exp $
inherit eutils
@@ -28,8 +28,9 @@ src_unpack() {
rm Makefile*
cp "${FILESDIR}/Makefile.am-${PV}" ./Makefile.am
automake
- # patch against hardcoded paths
+ # patches against hardcoded paths
epatch ${FILESDIR}/non-symlink-${PV}.patch
+ epatch ${FILESDIR}/info-location-${PV}.patch
}
src_compile() {