summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-01-12 20:02:46 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-01-12 20:02:46 +0000
commit7f8c32e20a456707d4646e361e6fc0df08cba991 (patch)
treeb0ef5b1373de90f6550b3ac94f7e4573e556e12b /dev-util/git
parentRaise STLport dependency again, we really need 5.1.0, also remove sparc for n... (diff)
downloadgentoo-2-7f8c32e20a456707d4646e361e6fc0df08cba991.tar.gz
gentoo-2-7f8c32e20a456707d4646e361e6fc0df08cba991.tar.bz2
gentoo-2-7f8c32e20a456707d4646e361e6fc0df08cba991.zip
Version bump + stable on Alpha. See bug #159822
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.4.49
-rw-r--r--dev-util/git/git-1.4.4.4.ebuild156
3 files changed, 171 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index fa8809952bf3..1be88a081c92 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.159 2007/01/09 07:59:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.160 2007/01/12 20:02:46 ferdy Exp $
+
+*git-1.4.4.4 (12 Jan 2007)
+
+ 12 Jan 2007; Fernando J. Pereda <ferdy@gentoo.org> +git-1.4.4.4.ebuild:
+ Version bump + stable on Alpha. See bug #159822
09 Jan 2007; Markus Rothe <corsair@gentoo.org> git-1.4.4.3.ebuild:
Stable on ppc64; bug #159822
diff --git a/dev-util/git/files/digest-git-1.4.4.4 b/dev-util/git/files/digest-git-1.4.4.4
new file mode 100644
index 000000000000..cb0ea3137344
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.4.4
@@ -0,0 +1,9 @@
+MD5 970aceba959e7fe92f065d7509e6db51 git-1.4.4.4.tar.bz2 888482
+RMD160 a507e7d636e771fb3ed03054d3d70e6758385c28 git-1.4.4.4.tar.bz2 888482
+SHA256 b2117774fb96d53f4b07d89df389ee0097f29637c859ec8fecc020cf37622657 git-1.4.4.4.tar.bz2 888482
+MD5 dc11d0b76012c59b5de42520e543a8e5 git-htmldocs-1.4.4.4.tar.bz2 325718
+RMD160 cf55f807769e8aa731d512b654e847089d25ea0e git-htmldocs-1.4.4.4.tar.bz2 325718
+SHA256 196e901cd416f48b8068a10914455a27aa542bc821f677a705a69fb950145975 git-htmldocs-1.4.4.4.tar.bz2 325718
+MD5 6d1cf748480cb6f50d4990660cca3921 git-manpages-1.4.4.4.tar.bz2 103840
+RMD160 488e8ad8514180ed1d2d2d0d5e948351d4092f29 git-manpages-1.4.4.4.tar.bz2 103840
+SHA256 73f136bd93683fa559b22c8770acaebce70699798f6797e840d23a2a5cffa3a4 git-manpages-1.4.4.4.tar.bz2 103840
diff --git a/dev-util/git/git-1.4.4.4.ebuild b/dev-util/git/git-1.4.4.4.ebuild
new file mode 100644
index 000000000000..8b6cca4e8be5
--- /dev/null
+++ b/dev-util/git/git-1.4.4.4.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.4.4.ebuild,v 1.1 2007/01/12 20:02:46 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ has_version app-arch/unzip || \
+ rm "${S}"/t/t5000-tar-tree.sh
+ use amd64 && \
+ rm "${S}"/t/t9200-git-cvsexportcommit.sh
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dev-perl/DBD-SQLite"
+ showpkgdeps git-instaweb "|| ( www-servers/lighttpd net-www/apache(SLOT=2) )"
+ echo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}