summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-28 15:34:45 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-28 15:34:45 +0000
commit49e5c6fc4b3032c26a7a943d3199ecc9a5bd25e4 (patch)
tree99700773bdd650b1ae1b009c530ff33b4b01e786 /dev-util/global
parentdo not move fuser to /bin, bug #469454 by Yuta SATOH (diff)
downloadgentoo-2-49e5c6fc4b3032c26a7a943d3199ecc9a5bd25e4.tar.gz
gentoo-2-49e5c6fc4b3032c26a7a943d3199ecc9a5bd25e4.tar.bz2
gentoo-2-49e5c6fc4b3032c26a7a943d3199ecc9a5bd25e4.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/global-6.2.9.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 74a0a3376f8f..ae09f11a625f 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.112 2013/06/03 20:57:31 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.113 2013/08/28 15:34:45 floppym Exp $
+
+*global-6.2.9 (28 Aug 2013)
+
+ 28 Aug 2013; Mike Gilbert <floppym@gentoo.org> +global-6.2.9.ebuild:
+ Version bump. Ebuild by Arfrever.
03 Jun 2013; Mike Gilbert <floppym@gentoo.org> -global-5.9.5.ebuild,
-global-5.9.7.ebuild, -global-6.1.ebuild, -global-6.2.1.ebuild,
diff --git a/dev-util/global/global-6.2.9.ebuild b/dev-util/global/global-6.2.9.ebuild
new file mode 100644
index 000000000000..662c9036e3fe
--- /dev/null
+++ b/dev-util/global/global-6.2.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.2.9.ebuild,v 1.1 2013/08/28 15:34:44 floppym Exp $
+
+EAPI="5"
+
+inherit elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="sys-devel/libtool
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}