summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
commit13da29fe2ea95da2dabaa3364529d2ad0f74a489 (patch)
tree635f08fbce2b45ae21ad42d289736c92aab2ad1b /dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild
parentmask for new versions of gnustep programs (diff)
downloadgentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.tar.gz
gentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.tar.bz2
gentoo-2-13da29fe2ea95da2dabaa3364529d2ad0f74a489.zip
Version bump on gnustep. Currently masked. This bumps all the unstable
builds to stable revisions. gcc3 is required for these packages.
Diffstat (limited to 'dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild')
-rw-r--r--dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild b/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild
new file mode 100644
index 000000000000..2b3f3177235a
--- /dev/null
+++ b/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-gui/gnustep-gui-0.8.0.ebuild,v 1.1 2002/09/03 19:25:36 raker Exp $
+
+DESCRIPTION="GNUstep AppKit implementation"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND=">=dev-util/gnustep-base-1.4.0
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ ./configure --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ || die "configure failed"
+
+ make LD_LIBRARY_PATH=$LD_LIBRARY_PATH || die
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
+
+}