summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-10-31 17:03:31 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-10-31 17:03:31 +0000
commit062397e7d82e017f80ed4a8c6c8034c080656696 (patch)
tree54ea8037dee20a9299299b2ef10166c759937468 /dev-util/imediff2/imediff2-1.1.2-r1.ebuild
parentAdd mtp USE-flag for media-plugins/audacious-plugins. (diff)
downloadgentoo-2-062397e7d82e017f80ed4a8c6c8034c080656696.tar.gz
gentoo-2-062397e7d82e017f80ed4a8c6c8034c080656696.tar.bz2
gentoo-2-062397e7d82e017f80ed4a8c6c8034c080656696.zip
Changed mirror to avoid version bump problems.
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-util/imediff2/imediff2-1.1.2-r1.ebuild')
-rw-r--r--dev-util/imediff2/imediff2-1.1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/imediff2/imediff2-1.1.2-r1.ebuild b/dev-util/imediff2/imediff2-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..9d4ce722cd48
--- /dev/null
+++ b/dev-util/imediff2/imediff2-1.1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/imediff2/imediff2-1.1.2-r1.ebuild,v 1.1 2007/10/31 17:03:30 dev-zero Exp $
+
+inherit eutils versionator
+
+KEYWORDS="~amd64 ~x86"
+
+MY_P=${PN}_$(replace_version_separator 3 -)
+
+DESCRIPTION="An interactive, user friendly 2-way merge tool in text mode."
+HOMEPAGE="http://elonen.iki.fi/code/imediff/"
+SRC_URI="mirror://debian/pool/main/i/${PN}/${MY_P}.orig.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/python"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use --missing true dev-lang/python ncurses ; then
+ eerror "dev-lang/python has to be built with ncurses support"
+ die "Missing ncurses USE-flag for dev-lang/python"
+ fi
+}
+
+src_compile() {
+ # Otherwise the docs get regenerated :)
+ einfo "Nothing to compile..."
+}
+
+src_install() {
+ dobin imediff2
+ dodoc AUTHORS README
+ doman imediff2.1
+}