summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-26 01:48:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-26 01:48:07 +0000
commit981625c22806e1f3eb7cd46098bb04353c0158a5 (patch)
tree933e15f271b4c6d118e73c17912a99672aba85d8 /dev-util/intel2gas/files
parentwhitespace (diff)
downloadgentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.tar.gz
gentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.tar.bz2
gentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.zip
QA fixes as per bug #255837 thanks kevin.pyle
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'dev-util/intel2gas/files')
-rw-r--r--dev-util/intel2gas/files/intel2gas-1.3.3-constchar.patch71
-rw-r--r--dev-util/intel2gas/files/intel2gas-1.3.3-cxx.patch10
-rw-r--r--dev-util/intel2gas/files/intel2gas-nostrip.patch12
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-util/intel2gas/files/intel2gas-1.3.3-constchar.patch b/dev-util/intel2gas/files/intel2gas-1.3.3-constchar.patch
new file mode 100644
index 000000000000..f749f9255d7c
--- /dev/null
+++ b/dev-util/intel2gas/files/intel2gas-1.3.3-constchar.patch
@@ -0,0 +1,71 @@
+--- intel2gas-1.3.3/intel2gas.cc.orig 2009-01-26 12:21:11.000000000 +1100
++++ intel2gas-1.3.3/intel2gas.cc 2009-01-26 12:38:54.000000000 +1100
+@@ -57,10 +57,6 @@
+ int counter = 0;
+ char* prev = 0;
+ while (l) {
+- if (int(l->name) > 0x10000000) {
+- printf("Error %d, prev=%s\n", counter, prev);
+- break;
+- }
+ if (!strcasecmp(name,l->name))
+ return l;
+ counter++;
+@@ -255,7 +251,7 @@
+ return len;
+ }
+
+-static int str_parse(syntaxlist_t *s, char *parse, char *outline);
++static int str_parse(syntaxlist_t *s, const char *parse, char *outline);
+
+ static int parsematch(char *text, char *parse)
+ {
+@@ -394,10 +390,10 @@
+ }
+
+
+-static int str_parse(syntaxlist_t *sl, char *parse, char *outline)
++static int str_parse(syntaxlist_t *sl, const char *parse, char *outline)
+ {
+ *outline = '\0';
+- parse = str_skipspace(parse);
++ parse = str_skipspace((char *)parse);
+ if (str_empty(parse))
+ return 0;
+
+@@ -412,7 +408,7 @@
+ return 0;
+ }
+ strcpy(tempstr, s->parseline);
+- int size = parsematch(parse, tempstr);
++ int size = parsematch((char *)parse, tempstr);
+ if (size) {
+ setTheseVars(s->assignments);
+ if (!str_empty(s->output))
+@@ -535,7 +531,7 @@
+ if (str_empty(var)) return;
+
+ static struct {
+- char *reg;
++ const char *reg;
+ int mask;
+ } reglist[] = {
+ {"bp",0x40000},{"ebp",0xc0000},
+@@ -717,7 +713,7 @@
+ static int load_syntax_files(char modedir[])
+ {
+ // Override the compiled in path
+- char *resource_path = getenv("I2G_DATA");
++ const char *resource_path = getenv("I2G_DATA");
+ if (resource_path == NULL)
+ resource_path = RESOURCE_PATH;
+
+@@ -768,7 +764,7 @@
+
+ static bool is_a_define_line(char const *line)
+ {
+- static char *keywords[] = {
++ static const char *keywords[] = {
+ "if","define","else","endif",NULL,
+ };
+ for (int i=0; keywords[i]; i++) {
diff --git a/dev-util/intel2gas/files/intel2gas-1.3.3-cxx.patch b/dev-util/intel2gas/files/intel2gas-1.3.3-cxx.patch
new file mode 100644
index 000000000000..6197f299ef10
--- /dev/null
+++ b/dev-util/intel2gas/files/intel2gas-1.3.3-cxx.patch
@@ -0,0 +1,10 @@
+--- intel2gas-1.3.3/Makefile.in.orig 2009-01-26 12:15:41.000000000 +1100
++++ intel2gas-1.3.3/Makefile.in 2009-01-26 12:15:50.000000000 +1100
+@@ -1,7 +1,6 @@
+ # intel2gas 1.3.3 (c)1999 Mikko Tiihonen (mikko.tiihonen@hut.fi)
+ # Makefile by brn (c.nentwich@cs.ucl.ac.uk)
+
+-CXX = g++
+
+ # CXXFLAGS = -O6 -mpentium -malign-jumps=2 -malign-functions=2 -malign-loops=2
+ # Just kidding :)
diff --git a/dev-util/intel2gas/files/intel2gas-nostrip.patch b/dev-util/intel2gas/files/intel2gas-nostrip.patch
new file mode 100644
index 000000000000..86f9f6844117
--- /dev/null
+++ b/dev-util/intel2gas/files/intel2gas-nostrip.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.in b/Makefile.in
+--- intel2gas-1.3.3/Makefile.in 2000-11-14 12:53:25.000000000 -0600
++++ intel2gas-1.3.3-r1/Makefile.in 2009-01-21 18:34:44.000000000 -0600
+@@ -45,7 +45,7 @@
+ cp -a $$datadir/* $(data_prefix)/$$datadir; \
+ done
+ install -m 755 -d $(prefix)/bin
+- install -s -m 755 intel2gas $(prefix)/bin
++ install -m 755 intel2gas $(prefix)/bin
+
+ uninstall:
+ for datadir in $(DATADIRS); do \