summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-23 16:56:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-23 16:56:15 +0000
commit2bb00e4ce6026e30a0fe5a4315f24456dcba6b83 (patch)
tree7d56b501117a7c6b6453c9cd1a5278984d7d9fb7 /dev-util/intltool/intltool-0.40.6-r1.ebuild
parentno xfce-base for ~mips (diff)
downloadgentoo-2-2bb00e4ce6026e30a0fe5a4315f24456dcba6b83.tar.gz
gentoo-2-2bb00e4ce6026e30a0fe5a4315f24456dcba6b83.tar.bz2
gentoo-2-2bb00e4ce6026e30a0fe5a4315f24456dcba6b83.zip
Add patched version (since I had it locally) for 0.40.6.
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/intltool/intltool-0.40.6-r1.ebuild')
-rw-r--r--dev-util/intltool/intltool-0.40.6-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/intltool/intltool-0.40.6-r1.ebuild b/dev-util/intltool/intltool-0.40.6-r1.ebuild
new file mode 100644
index 000000000000..611902c5a0f7
--- /dev/null
+++ b/dev-util/intltool/intltool-0.40.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intltool/intltool-0.40.6-r1.ebuild,v 1.1 2009/08/23 16:56:15 flameeyes Exp $
+
+EAPI=2
+
+inherit gnome.org eutils
+
+DESCRIPTION="Tools for extracting translatable strings from various sourcefiles"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-install.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/I18N-HOWTO || die "dodoc failed"
+}