summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-07 08:32:49 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-06-07 08:32:49 +0000
commit599b2fc1196ffc9b122d78a344b1246fad9479cd (patch)
treeb03b8fc30873fbd087027251fbc17fa70d651c88 /dev-util/itstool/itstool-1.1.3.ebuild
parentCleanup, monkeyd-fix-manpage-path.patch accepted upstream (diff)
downloadgentoo-2-599b2fc1196ffc9b122d78a344b1246fad9479cd.tar.gz
gentoo-2-599b2fc1196ffc9b122d78a344b1246fad9479cd.tar.bz2
gentoo-2-599b2fc1196ffc9b122d78a344b1246fad9479cd.zip
Version bump with better error handling. Drop old.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/itstool/itstool-1.1.3.ebuild')
-rw-r--r--dev-util/itstool/itstool-1.1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/itstool/itstool-1.1.3.ebuild b/dev-util/itstool/itstool-1.1.3.ebuild
new file mode 100644
index 000000000000..120e22b0ac07
--- /dev/null
+++ b/dev-util/itstool/itstool-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/itstool/itstool-1.1.3.ebuild,v 1.1 2012/06/07 08:32:48 tetromino Exp $
+
+EAPI="4"
+PYTHON_USE_WITH="xml"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are as-is
+LICENSE="GPL-3 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}