summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-05-01 21:03:07 +0000
committerDaniel Goller <morfic@gentoo.org>2006-05-01 21:03:07 +0000
commitadd678f65e1f40d39d62769334fe735e68bc6e20 (patch)
tree95db2436e50b36b314ec183a2580ba8eb64b8bac /dev-util/ketchup/ketchup-0.9.8.ebuild
parentVersion bump (diff)
downloadgentoo-2-add678f65e1f40d39d62769334fe735e68bc6e20.tar.gz
gentoo-2-add678f65e1f40d39d62769334fe735e68bc6e20.tar.bz2
gentoo-2-add678f65e1f40d39d62769334fe735e68bc6e20.zip
Bump to 0.9.8
(Portage version: 2.1_pre10)
Diffstat (limited to 'dev-util/ketchup/ketchup-0.9.8.ebuild')
-rw-r--r--dev-util/ketchup/ketchup-0.9.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/ketchup/ketchup-0.9.8.ebuild b/dev-util/ketchup/ketchup-0.9.8.ebuild
new file mode 100644
index 000000000000..faefe805f277
--- /dev/null
+++ b/dev-util/ketchup/ketchup-0.9.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ketchup/ketchup-0.9.8.ebuild,v 1.1 2006/05/01 21:03:07 morfic Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for updating or switching between versions of the Linux kernel source"
+HOMEPAGE="http://www.selenic.com/ketchup/wiki/"
+
+if [[ $PV == *_p* ]]; then
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+else
+ SRC_URI="http://www.selenic.com/ketchup/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_install() {
+ if [[ $PV == *_p* ]]; then
+ cd Ketchup* 2>/dev/null # nightly snapshots unpack into a directory
+ else
+ cd ${S}
+ fi
+
+ dobin ./ketchup || die "could not install script"
+
+ if use doc; then
+ doman ketchup.1 || die "could not install ketchup manual"
+ fi
+}