summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-28 22:57:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-28 22:57:13 +0000
commitb5d3caf6de6ad6bd3f53733df2e95e1112420ba1 (patch)
tree54dc3879576145bfcf614432ba47131057deeadc /dev-util/libconf
parentStable on ppc64 (diff)
downloadgentoo-2-b5d3caf6de6ad6bd3f53733df2e95e1112420ba1.tar.gz
gentoo-2-b5d3caf6de6ad6bd3f53733df2e95e1112420ba1.tar.bz2
gentoo-2-b5d3caf6de6ad6bd3f53733df2e95e1112420ba1.zip
Added fixes and patch for FreeBSD. ~x86-fbsd keyword added.
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'dev-util/libconf')
-rw-r--r--dev-util/libconf/ChangeLog6
-rw-r--r--dev-util/libconf/files/0.42.10-fbsd.patch51
-rw-r--r--dev-util/libconf/libconf-0.42.10-r1.ebuild28
3 files changed, 77 insertions, 8 deletions
diff --git a/dev-util/libconf/ChangeLog b/dev-util/libconf/ChangeLog
index fac4597c7ddb..2a822dc7777e 100644
--- a/dev-util/libconf/ChangeLog
+++ b/dev-util/libconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/libconf
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.42 2006/11/28 20:06:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.43 2006/11/28 22:57:13 dev-zero Exp $
+
+ 28 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.42.10-fbsd.patch, libconf-0.42.10-r1.ebuild:
+ Added fixes and patch for FreeBSD. ~x86-fbsd keyword added.
28 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
-libconf-0.42.00.ebuild, -libconf-0.42.00-r1.ebuild,
diff --git a/dev-util/libconf/files/0.42.10-fbsd.patch b/dev-util/libconf/files/0.42.10-fbsd.patch
new file mode 100644
index 000000000000..3baf1559dfe3
--- /dev/null
+++ b/dev-util/libconf/files/0.42.10-fbsd.patch
@@ -0,0 +1,51 @@
+--- bindings/c/src/conf2xml.c.orig 2006-11-28 09:49:23 +0100
++++ bindings/c/src/conf2xml.c 2006-11-28 09:49:34 +0100
+@@ -7,7 +7,6 @@
+ #include <string.h>
+ #include "conf2xml.h"
+
+-#include <error.h>
+ #include <errno.h>
+ /* #define ARGC(a) ((sizeof(a)/sizeof(a[0]))) */
+ /* #define STR_MAX_SIZE 256 */
+@@ -39,17 +38,17 @@
+
+ char * conf2xml (char *filename, char *template, char *template_options) {
+ STRLEN l;
+- if (my_perl == NULL) error (NOT_INITIALIZED, 0, "conf2xml has not been initialized. Call conf2xml_init first");
++ if (my_perl == NULL) errc (NOT_INITIALIZED, 0, "conf2xml has not been initialized. Call conf2xml_init first");
+
+ if (!template) {
+ template = malloc(sizeof(char));
+- if (!template) error (ENOMEM, ENOMEM, NULL);
++ if (!template) errc (ENOMEM, ENOMEM, NULL);
+ *template = '\0';
+ }
+
+ if (!template_options) {
+ template_options = malloc(sizeof(char));
+- if (!template_options) error (ENOMEM, ENOMEM, NULL);;
++ if (!template_options) errc (ENOMEM, ENOMEM, NULL);;
+ *template_options = '\0';
+ }
+
+@@ -66,7 +65,7 @@
+ 1
+ );
+ char *perl_code = malloc(sizeof(char) * code_length);
+- if (!perl_code) error (ENOMEM, ENOMEM, NULL);;
++ if (!perl_code) errc (ENOMEM, ENOMEM, NULL);;
+ *perl_code = '\0';
+ strncat(perl_code, perl_code1, strlen(perl_code1));
+ strncat(perl_code, filename, strlen(filename));
+--- bindings/python/src/setup.py.orig 2006-11-28 09:50:43 +0100
++++ bindings/python/src/setup.py 2006-11-28 09:50:50 +0100
+@@ -12,7 +12,6 @@
+ ext_modules=[
+ Extension(
+ 'conf2xml',
+- sources=['conf2xmlmodule.c'],
+- libraries=['dl'],
++ sources=['conf2xmlmodule.c']
+ )]
+ )
diff --git a/dev-util/libconf/libconf-0.42.10-r1.ebuild b/dev-util/libconf/libconf-0.42.10-r1.ebuild
index e43746940a8e..dff238ec761c 100644
--- a/dev-util/libconf/libconf-0.42.10-r1.ebuild
+++ b/dev-util/libconf/libconf-0.42.10-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10-r1.ebuild,v 1.2 2006/11/28 20:06:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10-r1.ebuild,v 1.3 2006/11/28 22:57:13 dev-zero Exp $
-inherit multilib toolchain-funcs
+inherit eutils multilib toolchain-funcs
MY_P=perl-Libconf-${PV}
@@ -12,7 +12,7 @@ SRC_URI="http://libconf.net/download/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="python ruby"
DEPEND="dev-lang/perl
@@ -25,7 +25,7 @@ S=${WORKDIR}/${MY_P}
bindings() {
local mybindings
- mybindings="c bash"
+ mybindings="bash"
use python && mybindings="${mybindings} python"
use ruby && mybindings="${mybindings} ruby"
echo ${mybindings}
@@ -35,20 +35,34 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ [[ ${USERLAND} == *BSD ]] && epatch "${FILESDIR}/${PV}-fbsd.patch"
+
# Multilib fix
sed -i \
-e "/^LIB_DIR/ { s:lib:$(get_libdir): }" \
-e 's/^CF=-Wall/CF=$(CFLAGS)/' \
- bindings/c/src/Makefile || die "bad sed"
+ bindings/c/src/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ /\t/' \
+ perl-Libconf/Makefile || die "sed failed"
+
+ sed -i \
+ -e '/^MAKE =/d' \
+ Makefile perl-Libconf/Makefile || die "sed failed"
}
src_compile() {
emake \
BINDINGS="$(bindings)" \
- CC=$(tc-getCC) || die "make failed"
+ CC=$(tc-getCC) \
+ || die "make failed"
}
src_install() {
- emake BINDINGS="$(bindings)" PREFIX="${D}/usr" DESTDIR="${D}" ROOT="${D}" install || die "emake install failed"
+ emake \
+ BINDINGS="$(bindings)" \
+ PREFIX="${D}/usr" DESTDIR="${D}" ROOT="${D}" \
+ CPA="cp -pR" install || die "emake install failed"
dodoc AUTHORS ChangeLog \
bindings/ruby/src/{AUTHORS,README} \
bindings/python/src/README