summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-05 19:44:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-05 19:44:01 +0000
commitcb22ab97c24af1833317e90664fecbbf2fed8753 (patch)
tree8f1055a88da19153def76213c647910a73d2bc12 /dev-util/mdds/mdds-9999.ebuild
parentRemoved no longer needed dependency (bug #545342) (diff)
downloadgentoo-2-cb22ab97c24af1833317e90664fecbbf2fed8753.tar.gz
gentoo-2-cb22ab97c24af1833317e90664fecbbf2fed8753.tar.bz2
gentoo-2-cb22ab97c24af1833317e90664fecbbf2fed8753.zip
Restore keywords, add live ebuild
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0B08240A96F66571)
Diffstat (limited to 'dev-util/mdds/mdds-9999.ebuild')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
new file mode 100644
index 000000000000..7c8ffc0e20eb
--- /dev/null
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/mdds-9999.ebuild,v 1.1 2015/04/05 19:44:01 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+
+inherit eutils toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == 9999 ]] || S=${WORKDIR}/${P/-/_}
+
+src_prepare(){
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}