summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 10:37:44 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 10:37:44 +0000
commitd055b2e83d8d9794c45fd1434ac5c77f3795a8ad (patch)
tree83f4a1875f9ed76d76d4712f6a6475e68155c9da /dev-util/meld
parentVersion bump (diff)
downloadgentoo-2-d055b2e83d8d9794c45fd1434ac5c77f3795a8ad.tar.gz
gentoo-2-d055b2e83d8d9794c45fd1434ac5c77f3795a8ad.tar.bz2
gentoo-2-d055b2e83d8d9794c45fd1434ac5c77f3795a8ad.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.8.5.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 5bf3a6bd2980..8c86544c9e98 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.180 2014/04/26 07:32:15 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.181 2014/05/31 10:37:44 pacho Exp $
+
+*meld-1.8.5 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +meld-1.8.5.ebuild:
+ Version bump
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -meld-1.7.0.ebuild,
-meld-1.8.1.ebuild, -meld-1.8.2.ebuild:
diff --git a/dev-util/meld/meld-1.8.5.ebuild b/dev-util/meld/meld-1.8.5.ebuild
new file mode 100644
index 000000000000..951549a2365c
--- /dev/null
+++ b/dev-util/meld/meld-1.8.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.8.5.ebuild,v 1.1 2014/05/31 10:37:44 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit eutils python-single-r1 gnome2
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+highlight gnome"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ highlight? ( >=dev-python/pygtksourceview-2.10[${PYTHON_USEDEP}] )
+ gnome? ( >=dev-python/gconf-python-2.22:2[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/gtk-doc-am
+ dev-util/intltool
+"
+
+src_prepare() {
+ # fix the prefix so its not in */local/*
+ sed -e "s:/usr/local:${EPREFIX}/usr:" \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # don't run scrollkeeper (with the wrong path),
+ # leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 6 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ doman meld.1
+}