summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-23 11:18:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-23 11:18:55 +0000
commit206aa4f4c2d03924bda7b33ea54232c7233bf43c (patch)
treec77db750c6da0c8b9cf19e5da9b1b46fb24756d2 /dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
parentupdate manifest (diff)
downloadgentoo-2-206aa4f4c2d03924bda7b33ea54232c7233bf43c.tar.gz
gentoo-2-206aa4f4c2d03924bda7b33ea54232c7233bf43c.tar.bz2
gentoo-2-206aa4f4c2d03924bda7b33ea54232c7233bf43c.zip
Make sure we strip with the target toolchain #148437.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-util/mingw-runtime/mingw-runtime-3.9.ebuild')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.9.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
index 63ab78fe0b54..a85789ec1879 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild,v 1.1 2006/09/17 07:03:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild,v 1.2 2006/09/23 11:18:55 vapier Exp $
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
@@ -20,6 +20,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
+RESTRICT="strip"
DEPEND=""
@@ -63,6 +64,7 @@ src_install() {
doins -r include/* || die
else
emake install DESTDIR="${D}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${D}"/usr/${CTARGET}/doc
dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
fi