summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-09-30 08:16:27 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-09-30 08:16:27 +0000
commit2ce4f9e580890888a4bd33815fee952a76aa81d4 (patch)
treee376f6ce43f4be49749e841fed8d3bdf6e4b901d /dev-util/mingw64-runtime
parentnet-fs/netatalk: Drop old, bump series 2 (diff)
downloadgentoo-2-2ce4f9e580890888a4bd33815fee952a76aa81d4.tar.gz
gentoo-2-2ce4f9e580890888a4bd33815fee952a76aa81d4.tar.bz2
gentoo-2-2ce4f9e580890888a4bd33815fee952a76aa81d4.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/ChangeLog8
-rw-r--r--dev-util/mingw64-runtime/metadata.xml8
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-3.0.0.ebuild82
3 files changed, 97 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/ChangeLog b/dev-util/mingw64-runtime/ChangeLog
index 43add82bdbf7..63d5ce65c9ae 100644
--- a/dev-util/mingw64-runtime/ChangeLog
+++ b/dev-util/mingw64-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mingw64-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.12 2013/06/20 14:39:13 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.13 2013/09/30 08:16:27 alonbl Exp $
+
+*mingw64-runtime-3.0.0 (30 Sep 2013)
+
+ 30 Sep 2013; Alon Bar-Lev <alonbl@gentoo.org> +mingw64-runtime-3.0.0.ebuild,
+ metadata.xml:
+ Version bump
*mingw64-runtime-2.0.8 (20 Jun 2013)
diff --git a/dev-util/mingw64-runtime/metadata.xml b/dev-util/mingw64-runtime/metadata.xml
index fb4199eb7afe..8949dbfe6532 100644
--- a/dev-util/mingw64-runtime/metadata.xml
+++ b/dev-util/mingw64-runtime/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>toolchain</herd>
+<use>
+ <flag name='idl'>
+ Install idl files.
+ </flag>
+ <flag name='tools'>
+ Build and install extra tools.
+ </flag>
+</use>
</pkgmetadata>
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-3.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-3.0.0.ebuild
new file mode 100644
index 000000000000..ed4c6409e165
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-3.0.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-3.0.0.ebuild,v 1.1 2013/09/30 08:16:27 alonbl Exp $
+
+EAPI=5
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only idl tools"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_configure() {
+ local extra_conf=()
+
+ if just_headers; then
+ extra_conf+=( --without-crt )
+ else
+ extra_conf+=(
+ --with-crt
+ $(use_with tools)
+ )
+ fi
+
+ case ${CTARGET} in
+ x86_64*) extra_conf+=( --disable-lib32 --enable-lib64 ) ;;
+ i?86*) extra_conf+=( --enable-lib32 --disable-lib64 ) ;;
+ *) die "Unsupported ${CTARGET}" ;;
+ esac
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ CHOST=${CTARGET} econf \
+ --prefix=/usr/${CTARGET} \
+ --includedir=/usr/${CTARGET}/usr/include \
+ --with-headers \
+ --enable-sdk \
+ $(use_enable idl) \
+ "${extra_conf[@]}"
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${ED}/usr/share"
+}