summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-12-28 10:52:14 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-12-28 10:52:14 +0000
commit190b577c92cef578107ea17cea8b837073178507 (patch)
treeb64072f3704feb330a8bd663f2280776ee8e5168 /dev-util/monotone
parentNew ebuild for bug #139818 (thanks to Paul Bredbury) (diff)
downloadgentoo-2-190b577c92cef578107ea17cea8b837073178507.tar.gz
gentoo-2-190b577c92cef578107ea17cea8b837073178507.tar.bz2
gentoo-2-190b577c92cef578107ea17cea8b837073178507.zip
version bump as per bug #149209. Thanks Jack Lloyd
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/ChangeLog7
-rw-r--r--dev-util/monotone/files/digest-monotone-0.323
-rw-r--r--dev-util/monotone/monotone-0.32.ebuild113
3 files changed, 122 insertions, 1 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index e0d43d7e2070..45fab7247000 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.28 2006/10/29 05:18:06 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.29 2006/12/28 10:52:14 dragonheart Exp $
+
+*monotone-0.32 (28 Dec 2006)
+
+ 28 Dec 2006; Daniel Black <dragonheart@gentoo.org> +monotone-0.32.ebuild:
+ version bump as per bug #149209. Thanks Jack Lloyd
29 Oct 2006; Daniel Black <dragonheart@gentoo.org> monotone-0.29.ebuild:
requires >=gcc-3.4 as per bug #146971 thanks to Petr Baudis
diff --git a/dev-util/monotone/files/digest-monotone-0.32 b/dev-util/monotone/files/digest-monotone-0.32
new file mode 100644
index 000000000000..1aa976ba258d
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.32
@@ -0,0 +1,3 @@
+MD5 98b7ac7d680c0ba768bf74628fa74de9 monotone-0.32.tar.gz 4840983
+RMD160 12c7992c62ff3ec9ec1fa2462a7ec532840dc129 monotone-0.32.tar.gz 4840983
+SHA256 24f183ddf26e08a3a28ee365e036938ba7fffcc2e1086d3a9bd4d62580e05b70 monotone-0.32.tar.gz 4840983
diff --git a/dev-util/monotone/monotone-0.32.ebuild b/dev-util/monotone/monotone-0.32.ebuild
new file mode 100644
index 000000000000..29c5b8bfd484
--- /dev/null
+++ b/dev-util/monotone/monotone-0.32.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.32.ebuild,v 1.1 2006/12/28 10:52:14 dragonheart Exp $
+
+inherit elisp-common flag-o-matic bash-completion eutils
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+IUSE="doc emacs ipv6 nls"
+
+RDEPEND=">=dev-libs/boost-1.33.1
+ sys-libs/zlib
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ doc? ( sys-apps/texinfo )"
+
+
+pkg_setup() {
+ enewgroup monotone
+ enewuser monotone -1 -1 /var/lib/monotone monotone
+ if [[ "$(gcc-version)" == "3.3" ]]; then
+ die 'requires >=gcc-3.4'
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls) \
+ $(use_enable ipv6)"
+
+ # more aggressive optimizations cause trouble with the crypto library
+ strip-flags
+ append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf ${myconf} || die "configure failed"
+ emake || die "Compilation failed"
+
+ if use doc; then
+ make html || die 'html compilation failed'
+ fi
+
+ use emacs && elisp-compile contrib/*.el
+}
+
+src_test() {
+ make check || die "self test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
+
+ dobashcompletion contrib/monotone.bash_completion
+
+ if use doc; then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
+ fi
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+ docinto contrib
+ dodoc contrib/*
+ newconfd "${FILESDIR}"/monotone.confd monotone
+ newinitd "${FILESDIR}"/monotone.initd monotone
+
+ insinto /etc/monotone ;
+ newins "${FILESDIR}"/hooks.lua hooks.lua
+ newins "${FILESDIR}"/read-permissions read-permissions
+ newins "${FILESDIR}"/write-permissions write-permissions
+
+ keepdir /var/lib/monotone/keys/ /var/log/montone /var/run/montone
+ fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
+ /var/log/monotone /var/run/montone
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ einfo
+ einfo "For details and instructions to upgrade from previous versions,"
+ einfo "please read /usr/share/doc/${PF}/UPGRADE.gz"
+ einfo
+ einfo " 1. edit /etc/conf.d/monotone"
+ einfo " 2. import the first keys to enable access with"
+ einfo " env HOME=${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
+ einfo " Thereafter, those with write permission can add other keys via"
+ einfo " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
+ einfo " can be used in the read-permission and write-permission files."
+ einfo " 3. adjust permisions in /etc/monotone/read-permissions"
+ einfo " and /etc/monotone/write-permissions"
+ einfo " 4. start the daemon: /etc/init.d/monotone start"
+ einfo " 5. make persistent: rc-update add monotone default"
+ einfo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}