summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-11-02 09:09:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-11-02 09:09:07 +0000
commit1b384fa29b0e66e15f77cc970310a74595ebe8e4 (patch)
treef01ce93ed4b260c4e93f83430acb31d92a1a8436 /dev-util/osc
parentStabilise latest on amd64 and x86 to ensure build is correct and matching wha... (diff)
downloadgentoo-2-1b384fa29b0e66e15f77cc970310a74595ebe8e4.tar.gz
gentoo-2-1b384fa29b0e66e15f77cc970310a74595ebe8e4.tar.bz2
gentoo-2-1b384fa29b0e66e15f77cc970310a74595ebe8e4.zip
Version bump to latest to fix crashes with new obs.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-util/osc')
-rw-r--r--dev-util/osc/ChangeLog8
-rw-r--r--dev-util/osc/osc-0.141.0.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-util/osc/ChangeLog b/dev-util/osc/ChangeLog
index 6cc65afa2db6..d6c1efe8e435 100644
--- a/dev-util/osc/ChangeLog
+++ b/dev-util/osc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/osc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.20 2013/09/10 13:03:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.21 2013/11/02 09:09:07 scarabeus Exp $
+
+*osc-0.141.0 (02 Nov 2013)
+
+ 02 Nov 2013; Tomáš Chvátal <scarabeus@gentoo.org> +osc-0.141.0.ebuild,
+ osc-9999.ebuild:
+ Version bump to latest to fix crashes with new obs.
10 Sep 2013; Tomáš Chvátal <scarabeus@gentoo.org> -osc-0.139.1.ebuild,
osc-0.140.1.ebuild:
diff --git a/dev-util/osc/osc-0.141.0.ebuild b/dev-util/osc/osc-0.141.0.ebuild
new file mode 100644
index 000000000000..a6e6aed19063
--- /dev/null
+++ b/dev-util/osc/osc-0.141.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.141.0.ebuild,v 1.1 2013/11/02 09:09:07 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/openSUSE/osc.git"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EXTRA_ECLASS="git-2"
+else
+ OBS_PROJECT="openSUSE:Tools"
+ EXTRA_ECLASS="obs-download"
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Command line tool for Open Build Service"
+HOMEPAGE="http://en.opensuse.org/openSUSE:OSC"
+
+[[ "${PV}" == "9999" ]] || SRC_URI="${OBS_URI}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ dev-python/pyxml[${PYTHON_USEDEP}]
+ app-arch/rpm[python,${PYTHON_USEDEP}]
+ dev-python/m2crypto[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+PDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-util/obs-service-meta
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.139.2-out-of-tree-build.patch
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dosym osc-wrapper.py /usr/bin/osc
+ keepdir /usr/lib/osc/source_validators
+ cd "${ED}"/usr/
+ find . -type f -exec sed -i 's|/usr/bin/build|/usr/bin/suse-build|g' {} +
+ find . -type f -exec sed -i 's|/usr/lib/build|/usr/libexec/suse-build|g' {} +
+ find . -type f -exec sed -i 's|/usr/lib/obs|/usr/libexec/obs|g' {} +
+ rm -f "${ED}"/usr/share/doc/${PN}*/TODO*
+}