summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-08 13:38:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-08 13:38:10 +0000
commit3add11f7d49b11976ce4ddb0cf8a67e409e5457d (patch)
tree25ad36c128deafe2d639806e391ea5db7d100041 /dev-util/patchelf
parentVersion bump. Removed old (diff)
downloadgentoo-2-3add11f7d49b11976ce4ddb0cf8a67e409e5457d.tar.gz
gentoo-2-3add11f7d49b11976ce4ddb0cf8a67e409e5457d.tar.bz2
gentoo-2-3add11f7d49b11976ce4ddb0cf8a67e409e5457d.zip
dev-util/patchelf: Fix linking of test, #455454
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/ChangeLog6
-rw-r--r--dev-util/patchelf/files/patchelf-0.6-test-build.patch14
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-util/patchelf/ChangeLog b/dev-util/patchelf/ChangeLog
index c99ea00bfca2..4dec40fbe616 100644
--- a/dev-util/patchelf/ChangeLog
+++ b/dev-util/patchelf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/patchelf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.6 2013/02/04 15:59:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.7 2013/03/08 13:38:10 jlec Exp $
+
+ 08 Mar 2013; Justin Lecher <jlec@gentoo.org>
+ files/patchelf-0.6-test-build.patch:
+ Fix linking of test, #455454
*patchelf-0.6-r1 (04 Feb 2013)
diff --git a/dev-util/patchelf/files/patchelf-0.6-test-build.patch b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
index 0b4dc90b0082..4d741b525ca0 100644
--- a/dev-util/patchelf/files/patchelf-0.6-test-build.patch
+++ b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
@@ -1,16 +1,18 @@
- tests/Makefile.am | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
+ tests/Makefile.am | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 9d9b6bc..effde41 100644
+index 9d9b6bc..f345f46 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
-@@ -12,37 +12,37 @@ main_scoped_SOURCES =
+@@ -11,38 +11,38 @@ simple_SOURCES = simple.c
+ main_scoped_SOURCES =
- main: main.o libfoo.so
+-main: main.o libfoo.so
- LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o main main.o -L . -lfoo
-+ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o main main.o -L . -lfoo
++main: main.o libfoo.so libbar.so
++ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o main main.o -L . -lfoo -lbar
main-scoped: main.o libfoo-scoped.so
- LD_LIBRARY_PATH=. gcc -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped