summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-08-05 15:16:05 +0000
committerDamon Conway <kabau@gentoo.org>2001-08-05 15:16:05 +0000
commit00e4b226cd44d6b13b57ccc281cd650eb0eef83b (patch)
treee8fb918f0cc5280502af21b5ade18bac740e0127 /dev-util/pccts
parentwhoops... quote problem fix try #2 (diff)
downloadgentoo-2-00e4b226cd44d6b13b57ccc281cd650eb0eef83b.tar.gz
gentoo-2-00e4b226cd44d6b13b57ccc281cd650eb0eef83b.tar.bz2
gentoo-2-00e4b226cd44d6b13b57ccc281cd650eb0eef83b.zip
Moving pccts-1.33.24-r1.ebuild from incoming to dev-util/pccts. This rev
fixes some include stat errors and adds -CC command-line switch.
Diffstat (limited to 'dev-util/pccts')
-rw-r--r--dev-util/pccts/files/digest-pccts-1.33.24-r11
-rw-r--r--dev-util/pccts/files/pccts-1.33.24-r1-gentoo.diff49
-rw-r--r--dev-util/pccts/pccts-1.33.24-r1.ebuild65
3 files changed, 115 insertions, 0 deletions
diff --git a/dev-util/pccts/files/digest-pccts-1.33.24-r1 b/dev-util/pccts/files/digest-pccts-1.33.24-r1
new file mode 100644
index 000000000000..8323202acd81
--- /dev/null
+++ b/dev-util/pccts/files/digest-pccts-1.33.24-r1
@@ -0,0 +1 @@
+MD5 c2b9f48b029fdc636c1dd7b1df716478 pccts133mr24.zip
diff --git a/dev-util/pccts/files/pccts-1.33.24-r1-gentoo.diff b/dev-util/pccts/files/pccts-1.33.24-r1-gentoo.diff
new file mode 100644
index 000000000000..6e09ef6aafa2
--- /dev/null
+++ b/dev-util/pccts/files/pccts-1.33.24-r1-gentoo.diff
@@ -0,0 +1,49 @@
+--- pccts/support/genmk/genmk.c Fri Aug 3 17:12:51 2001
++++ pccts/support/genmk/genmk-gentoo.c Fri Aug 3 17:12:14 2001
+@@ -7,6 +7,11 @@
+ * U of MN
+ */
+
++/* modified 20010803 by Peter Kadau
++ * for better fhs-compliance
++ * i.e. from "none" to "hmmm soso" ;-)
++ */
++
+ #include <stdio.h>
+ #include <string.h>
+ #include "pcctscfg.h" /* be sensitive to what ANTLR/DLG call the files */
+@@ -65,7 +70,7 @@
+ static int nondef_comp = 0; /* 1=compiler is non default */
+ static char *compilerCCC="CC";
+ static char *compilerCC="cc";
+-static char *pccts_path="/usr/local/pccts";
++static char *pccts_path="/usr/include/pccts";
+
+ #ifdef __STDC__
+ void help(void);
+@@ -356,7 +361,7 @@
+ { "-cfiles",1,pCFiles, "Additional files in C or C++ to compile"},
+ { "-sor",0,pSor, "Start of sorcerer group"},
+ { "-pccts_path",1,ppccts_path,
+- "Path for $PCCTS directory (default is /usr/local/pccts)"},
++ "Path for $PCCTS directory (default is /usr/include/pccts)"},
+ { "-compiler",1,pCompiler,
+ "Default compiler (default is CC/cc)"},
+ { "*", 0,pFile, "" }, /* anything else is a file */
+@@ -495,13 +500,13 @@
+ else printf("SCAN = %s%s\n", DIR(), dlg_class);
+
+ printf("PCCTS = %s\n",pccts_path);
+- printf("ANTLR_H = $(PCCTS)%sh\n", DirectorySymbol);
++ printf("ANTLR_H = $(PCCTS)\n");
+ if (num_sors>0) {
+- printf("SOR_H = $(PCCTS)%ssorcerer%sh\n", DirectorySymbol, DirectorySymbol);
++ printf("SOR_H = $(PCCTS)%ssorcerer\n", DirectorySymbol);
+ printf("SOR_LIB = $(PCCTS)%ssorcerer%slib\n",
+ DirectorySymbol, DirectorySymbol);
+ }
+- printf("BIN = $(PCCTS)%sbin\n", DirectorySymbol);
++ printf("BIN = %susr%sbin\n", DirectorySymbol, DirectorySymbol);
+ printf("ANTLR = $(BIN)%santlr\n", DirectorySymbol);
+ printf("DLG = $(BIN)%sdlg\n", DirectorySymbol);
+ if (num_sors>0) printf("SOR = $(BIN)%ssor\n", DirectorySymbol);
diff --git a/dev-util/pccts/pccts-1.33.24-r1.ebuild b/dev-util/pccts/pccts-1.33.24-r1.ebuild
new file mode 100644
index 000000000000..0aedceae8858
--- /dev/null
+++ b/dev-util/pccts/pccts-1.33.24-r1.ebuild
@@ -0,0 +1,65 @@
+# pccts-1.33.24-r2.ebuild
+# Distributed under the terms of the GNU General Public License, v2 or later
+# based on pccts-1.33.24.ebuild, written by:
+# Frédéric Brin <duckx@libertysurf.fr>, Jonas Berlin <jonas@berlin.vg>
+# Author: Peter Kadau <peter.kadau@web.de>
+# $HEADER$
+
+A="pccts133mr24.zip"
+S=${WORKDIR}/pccts
+DESCRIPTION="An embedded C/C++ parser generator"
+SRC_URI="http://www.polhode.com/${A}"
+HOMEPAGE="http://www.polhode.com/"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ try make MAKE="make ${MAKEOPTS}" COPT="${CFLAGS}"
+}
+
+src_install() {
+
+
+
+ # main binaries
+ exeinto /usr/bin
+ doexe bin/{antlr,dlg,genmk,sor}
+
+ # .c and .cpp files go into /usr/include/pccts also,
+ # because genmk looks for them for being included in output-files
+ # (which are c/c++) generated from grammar-files
+ # right now i include _everything_ just to make sure
+ # it doesn't break pccts-based projects
+ #
+ # if i dive further into the details of genmk.c
+ # it should be possible to put that stuff into /usr/share/pccts
+ #
+ # the M$ and MAC specific stuff gets _not_ included
+ #
+ # main includes
+ insinto /usr/include/pccts
+ doins h/*.{h,c,cpp}
+
+ # sorcerer includes
+ insinto /usr/include/pccts/sorcerer/include
+ doins sorcerer/h/*.h
+
+ # sorcerer libraries
+ insinto /usr/include/pccts/sorcerer/lib
+ doins sorcerer/lib/*.{h,c,cpp}
+
+ # documentation
+ # leaving out the M$ and MAC stuff
+ dodoc CHANGES* KNOWN_PROBLEMS* README RIGHTS history.txt history.ps
+ dodoc sorcerer/README sorcerer/UPDATES
+
+ # manual pages
+ doman dlg/dlg.1 antlr/antlr.1
+}