summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2005-12-27 03:21:32 +0000
committerJoel Martin <kanaka@gentoo.org>2005-12-27 03:21:32 +0000
commitee3f26d16faebdbc543c3d1aa929b689328adaa0 (patch)
treee8eaa2a0d70f888a6c5415604f12e09baa4d9b69 /dev-util/qmtest/qmtest-2.3.ebuild
parentBug #116769 - upstream accidently dropped a symbol. Note that 0.9.3* is packa... (diff)
downloadgentoo-2-ee3f26d16faebdbc543c3d1aa929b689328adaa0.tar.gz
gentoo-2-ee3f26d16faebdbc543c3d1aa929b689328adaa0.tar.bz2
gentoo-2-ee3f26d16faebdbc543c3d1aa929b689328adaa0.zip
Add CodeSourcery's qmtest test harness/suite, version 2.3
(Portage version: 2.0.53)
Diffstat (limited to 'dev-util/qmtest/qmtest-2.3.ebuild')
-rw-r--r--dev-util/qmtest/qmtest-2.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/qmtest/qmtest-2.3.ebuild b/dev-util/qmtest/qmtest-2.3.ebuild
new file mode 100644
index 000000000000..aba0ac58ced2
--- /dev/null
+++ b/dev-util/qmtest/qmtest-2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qmtest/qmtest-2.3.ebuild,v 1.1 2005/12/27 03:21:32 kanaka Exp $
+
+inherit eutils
+DESCRIPTION="CodeSourcery's test harness system"
+HOMEPAGE="http://www.codesourcery.com/qmtest/"
+MY_P=qm-${PV}
+SRC_URI="http://www.codesourcery.com/public/${PN}/${MY_P}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ python setup.py build || die "setup.py build failed"
+}
+
+src_install() {
+ python setup.py install --prefix ${D}/usr || die "setup.py install failed"
+}
+