summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-08-24 10:58:22 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-08-24 10:58:22 +0000
commit8c5d6c725ee111e896513d310c3e1d526ff0f5fb (patch)
treea06be8503cc5796040a4284dc8c433e0d16570be /dev-util/rootstrap/rootstrap-0.3.21.ebuild
parentmark 0.110 stable, add 0.114 (Manifest recommit) (diff)
downloadgentoo-2-8c5d6c725ee111e896513d310c3e1d526ff0f5fb.tar.gz
gentoo-2-8c5d6c725ee111e896513d310c3e1d526ff0f5fb.tar.bz2
gentoo-2-8c5d6c725ee111e896513d310c3e1d526ff0f5fb.zip
mark 0.3.19 stable, add 0.3.21
Diffstat (limited to 'dev-util/rootstrap/rootstrap-0.3.21.ebuild')
-rw-r--r--dev-util/rootstrap/rootstrap-0.3.21.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/rootstrap/rootstrap-0.3.21.ebuild b/dev-util/rootstrap/rootstrap-0.3.21.ebuild
new file mode 100644
index 000000000000..cb3321e86a27
--- /dev/null
+++ b/dev-util/rootstrap/rootstrap-0.3.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.21.ebuild,v 1.1 2004/08/24 10:58:22 lanius Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool for building complete Linux filesystem images"
+HOMEPAGE="http://packages.qa.debian.org/rootstrap"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SRC_URI="mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}.orig.tar.gz
+ mirror://debian/pool/main/r/rootstrap/rootstrap_${PV}-1.diff.gz"
+
+S=${WORKDIR}/rootstrap-${PV}.orig
+
+DEPEND="sys-kernel/usermode-sources
+ dev-util/debootstrap
+ app-arch/dpkg
+ dev-lang/python
+ app-text/docbook-sgml-utils"
+IUSE=""
+
+src_unpack() {
+ unpack rootstrap_${PV}.orig.tar.gz
+ epatch ${DISTDIR}/rootstrap_${PV}-1.diff.gz
+ cd ${S}
+ sed -i -e "s/docbook-to-man/docbook2man/" Makefile
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc COPYING
+}