summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2010-01-14 20:02:16 +0000
committerCarsten Lohrke <carlo@gentoo.org>2010-01-14 20:02:16 +0000
commit160a9e11e066d7099c249244f29bd32e57289a64 (patch)
treedf20df5ac935451d699874d5079391771611e144 /dev-util/stgit
parentMarking empy-3.3 ppc for bug 299383 (diff)
downloadgentoo-2-160a9e11e066d7099c249244f29bd32e57289a64.tar.gz
gentoo-2-160a9e11e066d7099c249244f29bd32e57289a64.tar.bz2
gentoo-2-160a9e11e066d7099c249244f29bd32e57289a64.zip
Add missing files for a complete run of the test-suite.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-util/stgit')
-rw-r--r--dev-util/stgit/ChangeLog9
-rw-r--r--dev-util/stgit/stgit-0.15-r1.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/dev-util/stgit/ChangeLog b/dev-util/stgit/ChangeLog
index e1be71ee08cd..2806aea55e5f 100644
--- a/dev-util/stgit/ChangeLog
+++ b/dev-util/stgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/stgit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.36 2009/11/11 16:09:34 hwoarang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.37 2010/01/14 20:02:16 carlo Exp $
+
+*stgit-0.15-r1 (14 Jan 2010)
+
+ 14 Jan 2010; Carsten Lohrke <carlo@gentoo.org> +stgit-0.15-r1.ebuild:
+ Add missing files for a complete run of the test-suite.
*stgit-0.15 (11 Nov 2009)
diff --git a/dev-util/stgit/stgit-0.15-r1.ebuild b/dev-util/stgit/stgit-0.15-r1.ebuild
new file mode 100644
index 000000000000..5ae3e8f2d053
--- /dev/null
+++ b/dev-util/stgit/stgit-0.15-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/stgit-0.15-r1.ebuild,v 1.1 2010/01/14 20:02:16 carlo Exp $
+
+EAPI="2"
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-missing-patches.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-util/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future. Reference should be the online
+# man pages. (As of this writing, they use 8.2.7).
+DEPEND="$RDEPEND
+ doc? (
+ =app-text/asciidoc-8.2*
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup () {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # setup.cfg defaults to ~ ... delete it instead of sed'ing
+ rm setup.cfg
+ distutils_src_prepare
+}
+
+src_compile() {
+ # git throws errors if it cannot write its config file
+ # thus feed it a dummy one
+ touch gitconfig
+ export GIT_CONFIG="${S}/gitconfig"
+
+ # preparation stuff done in the makefile
+ emake build || die "emake build failed"
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+
+ # do not call normal 'emake' s.t. Gentoo's Python handling
+ # can do its work
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # do not use 'emake install-*' as the pathes are wrong
+ # and fixing them is more work than just using the following
+ doman Documentation/*.1 || die "doman failed"
+ dohtml Documentation/*.html || die "dohtml failed"
+ fi
+
+ dobashcompletion stgit-completion.bash ${PN}
+}