summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-01 07:15:30 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-01 07:15:30 +0000
commitf1c11bbfe4df7909156d35b3f8cf8577f3aedb47 (patch)
tree8af62096f0e6fc97376f61bcca9fd7df6e6c3b9c /dev-util/umockdev/umockdev-0.6.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f1c11bbfe4df7909156d35b3f8cf8577f3aedb47.tar.gz
gentoo-2-f1c11bbfe4df7909156d35b3f8cf8577f3aedb47.tar.bz2
gentoo-2-f1c11bbfe4df7909156d35b3f8cf8577f3aedb47.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/umockdev/umockdev-0.6.ebuild')
-rw-r--r--dev-util/umockdev/umockdev-0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/umockdev/umockdev-0.6.ebuild b/dev-util/umockdev/umockdev-0.6.ebuild
new file mode 100644
index 000000000000..1ed12816cedf
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/umockdev/umockdev-0.6.ebuild,v 1.1 2014/03/01 07:15:30 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit python-any-r1 autotools-utils
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/udev[gudev]
+ >=dev-libs/glib-2.32:2"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+RESTRICT="test"