summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-08-04 21:38:19 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-08-04 21:38:19 +0000
commit36f6ebc19685117f92c612a99155a21181609782 (patch)
tree4c95cf9c7d6f9936b53122d8b02ba6890c366cf7 /dev-util/valgrind/files
parentRemove djvu until new version released (diff)
downloadgentoo-2-36f6ebc19685117f92c612a99155a21181609782.tar.gz
gentoo-2-36f6ebc19685117f92c612a99155a21181609782.tar.bz2
gentoo-2-36f6ebc19685117f92c612a99155a21181609782.zip
Added new valgrind releases 2.4.1 and 3.0.0
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/valgrind/files')
-rw-r--r--dev-util/valgrind/files/digest-valgrind-2.4.11
-rw-r--r--dev-util/valgrind/files/digest-valgrind-3.0.01
-rw-r--r--dev-util/valgrind/files/valgrind-2.4.1-dont-trample-cflags.patch19
-rw-r--r--dev-util/valgrind/files/valgrind-2.4.1-static-const.patch132
-rw-r--r--dev-util/valgrind/files/valgrind-3.0.0-pie-fix.patch24
5 files changed, 177 insertions, 0 deletions
diff --git a/dev-util/valgrind/files/digest-valgrind-2.4.1 b/dev-util/valgrind/files/digest-valgrind-2.4.1
new file mode 100644
index 000000000000..66fcf4f52b5e
--- /dev/null
+++ b/dev-util/valgrind/files/digest-valgrind-2.4.1
@@ -0,0 +1 @@
+MD5 8ada0f37ddd940032b85ea859fedb037 valgrind-2.4.1.tar.bz2 1078229
diff --git a/dev-util/valgrind/files/digest-valgrind-3.0.0 b/dev-util/valgrind/files/digest-valgrind-3.0.0
new file mode 100644
index 000000000000..617bd30a1217
--- /dev/null
+++ b/dev-util/valgrind/files/digest-valgrind-3.0.0
@@ -0,0 +1 @@
+MD5 e976a343c61d9505162f595a8aeb09c1 valgrind-3.0.0.tar.bz2 2679021
diff --git a/dev-util/valgrind/files/valgrind-2.4.1-dont-trample-cflags.patch b/dev-util/valgrind/files/valgrind-2.4.1-dont-trample-cflags.patch
new file mode 100644
index 000000000000..452a45e08f4f
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-2.4.1-dont-trample-cflags.patch
@@ -0,0 +1,19 @@
+diff -ruN valgrind-2.4.1/configure valgrind-2.4.1-fixed/configure
+--- valgrind-2.4.1/configure 2005-08-03 22:12:16.789460240 +0200
++++ valgrind-2.4.1-fixed/configure 2005-08-03 22:14:38.055984464 +0200
+@@ -4735,6 +4735,7 @@
+ if test "$handles_mmmx" = "yes"; then
+ USE_MMX_REGISTER="-mmmx"
+ fi
++CFLAGS=$safe_CFLAGS
+
+
+
+@@ -4804,6 +4805,7 @@
+ if test "$handles_msse" = "yes"; then
+ USE_SSE_REGISTER="-msse"
+ fi
++CFLAGS=$safe_CFLAGS
+
+
+
diff --git a/dev-util/valgrind/files/valgrind-2.4.1-static-const.patch b/dev-util/valgrind/files/valgrind-2.4.1-static-const.patch
new file mode 100644
index 000000000000..8d13a4f7e8b4
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-2.4.1-static-const.patch
@@ -0,0 +1,132 @@
+diff -ruN valgrind-2.4.1/coregrind/vg_memory.c valgrind-2.4.1-fixed/coregrind/vg_memory.c
+--- valgrind-2.4.1/coregrind/vg_memory.c 2005-07-19 21:13:46.000000000 +0200
++++ valgrind-2.4.1-fixed/coregrind/vg_memory.c 2005-08-03 23:02:13.570880216 +0200
+@@ -158,7 +158,7 @@
+ {
+ Segment *s;
+ Segment *next;
+- static const Bool debug = False || mem_debug;
++ const Bool debug = False || mem_debug;
+ Addr end;
+
+ if (len == 0)
+@@ -324,7 +324,7 @@
+ UInt dev, UInt ino, ULong off, const Char *filename)
+ {
+ Segment *s;
+- static const Bool debug = False || mem_debug;
++ const Bool debug = False || mem_debug;
+ Bool recycled;
+
+ if (debug)
+@@ -479,7 +479,7 @@
+ void VG_(mprotect_range)(Addr a, SizeT len, UInt prot)
+ {
+ Segment *s, *next;
+- static const Bool debug = False || mem_debug;
++ const Bool debug = False || mem_debug;
+ Segment *s1, *s2;
+
+ if (debug)
+@@ -524,7 +524,7 @@
+
+ Addr VG_(find_map_space)(Addr addr, SizeT len, Bool for_client)
+ {
+- static const Bool debug = False || mem_debug;
++ const Bool debug = False || mem_debug;
+ Segment *s;
+ Addr ret;
+ Addr limit = (for_client ? VG_(client_end)-1 : VG_(valgrind_last));
+diff -ruN valgrind-2.4.1/coregrind/vg_stabs.c valgrind-2.4.1-fixed/coregrind/vg_stabs.c
+--- valgrind-2.4.1/coregrind/vg_stabs.c 2005-07-27 14:37:52.000000000 +0200
++++ valgrind-2.4.1-fixed/coregrind/vg_stabs.c 2005-08-03 23:03:07.065747760 +0200
+@@ -123,7 +123,7 @@
+ */
+ static SymType *structRef(StabTypeTab *tab, SymType *def, Bool isstruct, Char *name)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ struct structlist *sl;
+ SymType *ty;
+ static Int warnlen = 0;
+@@ -168,7 +168,7 @@
+ /* Add a structural defintion for a struct/union reference */
+ static SymType *structDef(StabTypeTab *tab, SymType *def, Bool isstruct, Char *name)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ SymType *ref = structRef(tab, NULL, isstruct, name);
+
+ /* it seems that GNAT likes to declare names as both struct tags
+@@ -236,7 +236,7 @@
+ /* add a new index for a file */
+ static void addFileAlias(StabTypeTab *tab, Char *filename, UInt instance, Int idx)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ struct header *hp;
+
+ for(hp = tab->headerhash[header_hash(filename, instance)]; hp != NULL; hp = hp->next) {
+@@ -255,7 +255,7 @@
+
+ static void addHeader(StabTypeTab *tab, Char *filename, UInt instance, Int idx)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ struct header *hp, **bucket;
+
+ if (debug)
+@@ -476,7 +476,7 @@
+
+ static void stab_resolve(SymType *st, void *data)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ Char *str = (Char *)data;
+ vg_assert(!VG_(st_isresolved)(st));
+
+@@ -493,7 +493,7 @@
+ introduced anywhere, so we need to scan it all to pick them up. */
+ static SymType *stabtype_parser(SegInfo *si, SymType *def, Char **pp)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ Char *p = *pp;
+ Char t;
+ SymType *type;
+@@ -1018,7 +1018,7 @@
+ /* parse a symbol reference: NAME ':' DESC TYPE */
+ static Bool initSym(SegInfo *si, Sym *sym, stab_types kind, Char **namep, Int val)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ Char *name = *namep;
+ Char *ty;
+ Int len;
+@@ -1159,7 +1159,7 @@
+ definitions helps a lot. */
+ static Scope *addSymsToScope(Scope *sc, struct symlist *list, Int nsyms, Scope *outer)
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ Int j;
+ struct symlist *n;
+ Int base;
+@@ -1205,7 +1205,7 @@
+ UChar* stabC, Int stab_sz,
+ UChar* stabstr, Int stabstr_sz )
+ {
+- static const Bool debug = False || stabs_debug;
++ const Bool debug = False || stabs_debug;
+ Int i;
+ Int n_stab_entries;
+ struct nlist* stab = (struct nlist*)stabC;
+@@ -1283,7 +1283,7 @@
+
+ /* handle continued string stabs */
+ {
+- static const Bool contdebug = False || stabs_debug;
++ const Bool contdebug = False || stabs_debug;
+ Int buflen = 0;
+ Int idx = 0;
+ Char *buf = NULL;
diff --git a/dev-util/valgrind/files/valgrind-3.0.0-pie-fix.patch b/dev-util/valgrind/files/valgrind-3.0.0-pie-fix.patch
new file mode 100644
index 000000000000..8919eeb2506a
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.0.0-pie-fix.patch
@@ -0,0 +1,24 @@
+diff -ruN valgrind-3.0.0/none/tests/x86/Makefile.in valgrind-3.0.0-fixed/none/tests/x86/Makefile.in
+--- valgrind-3.0.0/none/tests/x86/Makefile.in 2005-08-03 22:43:14.000000000 +0200
++++ valgrind-3.0.0-fixed/none/tests/x86/Makefile.in 2005-08-04 22:52:05.563599512 +0200
+@@ -151,7 +151,7 @@
+ CCAS = @CCAS@
+ CCASFLAGS = @CCASFLAGS@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-pie
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+diff -ruN valgrind-3.0.0/tests/Makefile.in valgrind-3.0.0-fixed/tests/Makefile.in
+--- valgrind-3.0.0/tests/Makefile.in 2005-08-03 22:43:14.000000000 +0200
++++ valgrind-3.0.0-fixed/tests/Makefile.in 2005-08-04 22:52:15.937022512 +0200
+@@ -93,7 +93,7 @@
+ CCAS = @CCAS@
+ CCASFLAGS = @CCASFLAGS@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-pie
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@