summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-07-04 20:37:35 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-07-04 20:37:35 +0000
commitc6501f05fed5381e9ba89de1c2fe93702971439c (patch)
tree989a08406155500594c5ae093a171f7a65cbbeca /dev-util/wxglade
parentRemove old versions no longer available. Thanks to Mark Loeser for reporting. (diff)
downloadgentoo-2-c6501f05fed5381e9ba89de1c2fe93702971439c.tar.gz
gentoo-2-c6501f05fed5381e9ba89de1c2fe93702971439c.tar.bz2
gentoo-2-c6501f05fed5381e9ba89de1c2fe93702971439c.zip
Support multiple python ABIs. (bug #326125)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/wxglade')
-rw-r--r--dev-util/wxglade/ChangeLog7
-rw-r--r--dev-util/wxglade/wxglade-0.6.3-r1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/wxglade/ChangeLog b/dev-util/wxglade/ChangeLog
index ad3a1bf1d0bc..896129c5e2aa 100644
--- a/dev-util/wxglade/ChangeLog
+++ b/dev-util/wxglade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/wxglade
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.52 2010/03/08 00:52:31 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.53 2010/07/04 20:37:35 dirtyepic Exp $
+
+*wxglade-0.6.3-r1 (04 Jul 2010)
+
+ 04 Jul 2010; Ryan Hill <dirtyepic@gentoo.org> +wxglade-0.6.3-r1.ebuild:
+ Support multiple python ABIs. (bug #326125)
08 Mar 2010; Jonathan Callen <abcd@gentoo.org> wxglade-0.6.3.ebuild:
Move PYTHON_DEPEND before inherit(), so that the dep is actually added
diff --git a/dev-util/wxglade/wxglade-0.6.3-r1.ebuild b/dev-util/wxglade/wxglade-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..405769f3e072
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.6.3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.3-r1.ebuild,v 1.1 2010/07/04 20:37:35 dirtyepic Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils multilib python
+
+MY_P="wxGlade-${PV}"
+
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/wxpython:2.8"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxversion.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodoc CHANGES.txt README.txt TODO.txt
+ insinto /usr/share/pixmaps
+ newins icons/icon.xpm wxglade.xpm || die "installing wxglade.xpm failed"
+ doman "${S}"/debian/wxglade.1 || die "installing man failed"
+ rm -rf "${S}"/debian
+ dohtml -r "${S}"/docs/* || die "installing docs failied"
+ rm -rf "${S}"/docs
+
+ python_copy_sources
+
+ installation() {
+ pydir=$(python_get_sitedir)/${PN}
+ insinto "${pydir}"
+ doins "${S}"/credits.txt || die "installing credits.txt failed"
+ doins -r ./* || die "installing failed"
+ dosym /usr/share/doc/${PF}/html "${pydir}"/docs || die "doc symlink failed"
+ fperms 775 "${pydir}"/wxglade.py
+ dosym "${pydir}"/wxglade.py /usr/bin/wxglade-$(python_get_version) \
+ || die "main symlink failed"
+ }
+ python_execute_function -s installation
+
+ python_generate_wrapper_scripts -E -f -q "${D}"usr/bin/wxglade
+
+ make_desktop_entry wxglade wxGlade wxglade "Development;GUIDesigner"
+}
+
+pkg_postinst() {
+ python_mod_optimize wxglade
+}
+
+pkg_postrm() {
+ python_mod_cleanup wxglade
+}