summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-29 16:50:57 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-29 16:50:57 +0000
commitce2b1516ec8c3df15e082be759ba2c52f3883307 (patch)
treebe4e1757e7dfb3710a8185ab74a74bc99bd1c3c2 /dev-util/wxglade
parentpython_mod_optimize is ROOT aware. Multilib love. (diff)
downloadgentoo-2-ce2b1516ec8c3df15e082be759ba2c52f3883307.tar.gz
gentoo-2-ce2b1516ec8c3df15e082be759ba2c52f3883307.tar.bz2
gentoo-2-ce2b1516ec8c3df15e082be759ba2c52f3883307.zip
python_mod_{cleanup,optimize} are ROOT aware.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-util/wxglade')
-rw-r--r--dev-util/wxglade/ChangeLog6
-rw-r--r--dev-util/wxglade/wxglade-0.6.1.ebuild7
-rw-r--r--dev-util/wxglade/wxglade-0.6.3.ebuild7
-rw-r--r--dev-util/wxglade/wxglade-0.6.ebuild9
4 files changed, 18 insertions, 11 deletions
diff --git a/dev-util/wxglade/ChangeLog b/dev-util/wxglade/ChangeLog
index e1e48d5bb37d..d55984a9d3d2 100644
--- a/dev-util/wxglade/ChangeLog
+++ b/dev-util/wxglade/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/wxglade
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.46 2008/03/11 03:36:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.47 2008/05/29 16:50:57 hawking Exp $
+
+ 29 May 2008; Ali Polatel <hawking@gentoo.org> wxglade-0.6.ebuild,
+ wxglade-0.6.1.ebuild, wxglade-0.6.3.ebuild:
+ python_mod_{cleanup,optimize} are ROOT aware.
*wxglade-0.6.3 (11 Mar 2008)
diff --git a/dev-util/wxglade/wxglade-0.6.1.ebuild b/dev-util/wxglade/wxglade-0.6.1.ebuild
index d89ae4c181dc..e8500bfbb850 100644
--- a/dev-util/wxglade/wxglade-0.6.1.ebuild
+++ b/dev-util/wxglade/wxglade-0.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.1.ebuild,v 1.3 2008/04/02 20:06:41 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.1.ebuild,v 1.4 2008/05/29 16:50:57 hawking Exp $
inherit python multilib eutils
@@ -42,7 +42,8 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "${ROOT}"usr/$(get_libdir)/python*/site-packages/wxglade
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/wxglade
}
pkg_postrm() {
diff --git a/dev-util/wxglade/wxglade-0.6.3.ebuild b/dev-util/wxglade/wxglade-0.6.3.ebuild
index 1b480f95c82a..e059f752b060 100644
--- a/dev-util/wxglade/wxglade-0.6.3.ebuild
+++ b/dev-util/wxglade/wxglade-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.3.ebuild,v 1.2 2008/04/02 20:06:41 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.3.ebuild,v 1.3 2008/05/29 16:50:57 hawking Exp $
inherit python multilib eutils
@@ -42,9 +42,10 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "${ROOT}"usr/$(get_libdir)/python*/site-packages/wxglade
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/wxglade
}
pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/wxglade
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/wxglade
}
diff --git a/dev-util/wxglade/wxglade-0.6.ebuild b/dev-util/wxglade/wxglade-0.6.ebuild
index ae60e1d5ff17..aab2f48c4558 100644
--- a/dev-util/wxglade/wxglade-0.6.ebuild
+++ b/dev-util/wxglade/wxglade-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.ebuild,v 1.8 2007/12/05 16:25:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.6.ebuild,v 1.9 2008/05/29 16:50:57 hawking Exp $
inherit python multilib eutils
@@ -42,9 +42,10 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "${ROOT}"usr/$(get_libdir)/python*/site-packages/wxglade
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/wxglade
}
pkg_postrm() {
- python_mod_cleanup "${ROOT}"usr/$(get_libdir)/python*/site-packages/wxglade
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/wxglade
}