summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-12 08:25:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-12 08:25:14 +0000
commit10d91ba0525bb70c36510375cafbe08c079b3348 (patch)
treebadb1ffe1c21c28fdea31b68fa69e51d25725b6f /dev-util
parentold (diff)
downloadgentoo-2-10d91ba0525bb70c36510375cafbe08c079b3348.tar.gz
gentoo-2-10d91ba0525bb70c36510375cafbe08c079b3348.tar.bz2
gentoo-2-10d91ba0525bb70c36510375cafbe08c079b3348.zip
Overhaul
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rcsi/rcsi-0.5.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-util/rcsi/rcsi-0.5.ebuild b/dev-util/rcsi/rcsi-0.5.ebuild
index 51dfd67ed05e..5003fbbc125f 100644
--- a/dev-util/rcsi/rcsi-0.5.ebuild
+++ b/dev-util/rcsi/rcsi-0.5.ebuild
@@ -1,33 +1,35 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rcsi/rcsi-0.5.ebuild,v 1.2 2005/05/07 17:02:04 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rcsi/rcsi-0.5.ebuild,v 1.3 2009/10/12 08:25:14 ssuominen Exp $
+
+inherit toolchain-funcs
-inherit eutils toolchain-funcs
DESCRIPTION="A program to give information about RCS files"
-URI_BASE="http://www.colinbrough.pwp.blueyonder.co.uk"
-HOMEPAGE="${URI_BASE}/rcsi.README.html"
-SRC_URI="${URI_BASE}/${P}.tar.gz"
+HOMEPAGE="http://www.colinbrough.pwp.blueyonder.co.uk/rcsi.README.html"
+SRC_URI="http://www.colinbrough.pwp.blueyonder.co.uk/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
+
DEPEND="sys-apps/sed"
RDEPEND=">=app-text/rcs-5.7-r2"
-S="${WORKDIR}/${PN}"
+
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- # Make the upstream Makefile honour $CC and optimisations.
CC="$(tc-getCC)"
- sed -e "s^gcc -Wall -O2 -Xlinker -s^${CC} -Wall ${CFLAGS}^g" -i ${S}/Makefile
+ sed -e "s^gcc -Wall -O2 -Xlinker -s^${CC} -Wall ${CFLAGS}^g" -i "${S}"/Makefile
}
src_compile() {
- emake -j1 rcsi
+ emake -j1 rcsi || die
}
src_install() {
- dobin rcsi
+ dobin rcsi || die
doman rcsi.1
dodoc README
dohtml README.html example{1,2}.png