summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-04-04 07:51:26 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-04-04 07:51:26 +0000
commit1407a135175866a634ee5dee5f298980d8fb834c (patch)
tree6a2ad76921fc3be4513845f38f7071e997d4aaed /dev-util
parentBump ieee754 to 0.7.6 (diff)
downloadgentoo-2-1407a135175866a634ee5dee5f298980d8fb834c.tar.gz
gentoo-2-1407a135175866a634ee5dee5f298980d8fb834c.tar.bz2
gentoo-2-1407a135175866a634ee5dee5f298980d8fb834c.zip
Version bump rebar to 2.5.0
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rebar/ChangeLog7
-rw-r--r--dev-util/rebar/rebar-2.5.0.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-util/rebar/ChangeLog b/dev-util/rebar/ChangeLog
index ce92b66dea6d..0f176c089b0b 100644
--- a/dev-util/rebar/ChangeLog
+++ b/dev-util/rebar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/rebar
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.9 2015/01/17 14:21:14 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/ChangeLog,v 1.10 2015/04/04 07:51:26 djc Exp $
+
+*rebar-2.5.0 (04 Apr 2015)
+
+ 04 Apr 2015; Dirkjan Ochtman <djc@gentoo.org> +rebar-2.5.0.ebuild:
+ Version bump rebar to 2.5.0
17 Jan 2015; Dirkjan Ochtman <djc@gentoo.org> -rebar-2.2.0.ebuild,
-rebar-2.3.0.ebuild:
diff --git a/dev-util/rebar/rebar-2.5.0.ebuild b/dev-util/rebar/rebar-2.5.0.ebuild
new file mode 100644
index 000000000000..de89d7b97bf2
--- /dev/null
+++ b/dev-util/rebar/rebar-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rebar/rebar-2.5.0.ebuild,v 1.1 2015/04/04 07:51:26 djc Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="http://github.com/rebar/rebar"
+SRC_URI="http://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}