summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-03-22 19:03:27 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-03-22 19:03:27 +0000
commit1e824af87f1035f5ab2b97fcb7734d1d941535d7 (patch)
tree0330bd84438dfa62235014d255b70e6505fc0dfb /dev-util
parentRemove old. (diff)
downloadgentoo-2-1e824af87f1035f5ab2b97fcb7734d1d941535d7.tar.gz
gentoo-2-1e824af87f1035f5ab2b97fcb7734d1d941535d7.tar.bz2
gentoo-2-1e824af87f1035f5ab2b97fcb7734d1d941535d7.zip
Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/nsis/ChangeLog5
-rw-r--r--dev-util/nsis/nsis-2.46.ebuild113
2 files changed, 4 insertions, 114 deletions
diff --git a/dev-util/nsis/ChangeLog b/dev-util/nsis/ChangeLog
index 5730e9b12fa4..53aef2ace46a 100644
--- a/dev-util/nsis/ChangeLog
+++ b/dev-util/nsis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/nsis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.44 2014/01/26 11:02:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.45 2014/03/22 19:03:27 kensington Exp $
+
+ 22 Mar 2014; Michael Palimaka <kensington@gentoo.org> -nsis-2.46.ebuild:
+ Remove old.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> nsis-2.46-r1.ebuild:
Stable for x86, wrt bug #495676
diff --git a/dev-util/nsis/nsis-2.46.ebuild b/dev-util/nsis/nsis-2.46.ebuild
deleted file mode 100644
index 29bb061af6c7..000000000000
--- a/dev-util/nsis/nsis-2.46.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.46.ebuild,v 1.4 2013/03/03 12:10:25 xarthisius Exp $
-
-EAPI="2"
-mingw32_variants=$(echo {,i{6,5,4,3}86-{,pc-}}mingw32)
-
-inherit eutils
-
-DESCRIPTION="Nullsoft Scriptable Install System"
-HOMEPAGE="http://nsis.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
-
-LICENSE="ZLIB BZIP2 CPL-1.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="bzip2 config-log doc zlib"
-RESTRICT="strip"
-
-# NSIS Menu uses wxwindows but it's all broken, so disable for now
-# wxwindows? ( x11-libs/wxGTK )
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- >=dev-util/scons-0.98"
-
-S="${WORKDIR}"/${P}-src
-
-mingw_CTARGET() {
- local i
- for i in ${mingw32_variants} ; do
- type -P ${i}-gcc > /dev/null && echo ${i} && return
- done
-}
-
-pkg_setup() {
- [[ -n $(mingw_CTARGET) ]] && return 0
-
- local i
- eerror "Before you could emerge nsis, you need to install mingw32."
- eerror "Run the following command:"
- eerror " emerge crossdev"
- eerror "then run _one_ of the following commands:"
- for i in ${mingw32_variants} ; do
- eerror " crossdev ${i}"
- done
- die "mingw32 is needed"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc47.patch
- # a dirty but effective way of killing generated docs
- use doc || echo > Docs/src/SConscript
-}
-
-get_additional_options() {
- echo \
- PREFIX=/usr \
- PREFIX_CONF=/etc \
- PREFIX_DOC=/usr/share/doc/${PF} \
- PREFIX_DEST=\"${D}\" \
- VERSION=${PV} \
- DEBUG=no \
- STRIP=no
- echo \
- SKIPSTUBS=\"$(use zlib || echo zlib) $(use bzip2 || echo bzip2)\" \
- SKIPUTILS=\"NSIS Menu\"
- use config-log && echo NSIS_CONFIG_LOG=yes
- # remove the following line when nsis bug 1753070 will be fixed
- use amd64 && echo APPEND_CCFLAGS=-m32 APPEND_LINKFLAGS=-m32
-
- local tcpfx=$($(mingw_CTARGET)-gcc -print-file-name=libshell32.a)
- tcpfx=${tcpfx%/lib/libshell32.a}
- echo \
- PREFIX_PLUGINAPI_INC=${tcpfx}/include \
- PREFIX_PLUGINAPI_LIB=${tcpfx}/lib
-}
-
-do_scons() {
- local cmd=$1
- eval set -- $(get_additional_options)
- echo scons $(get_additional_options) ${cmd}
- scons "$@" ${cmd}
-}
-
-src_compile() {
- do_scons || die "scons failed"
-}
-
-src_install() {
- do_scons install || die "scons failed"
- use doc || rm -rf "${D}"/usr/share/doc/${PF}/{Docs,Examples}
-
- fperms -R go-w,a-x,a+X /usr/share/${PN}/ /usr/share/doc/${PF}/ /etc/nsisconf.nsh
-
- env -uRESTRICT prepstrip "${D}/usr/bin"
- src_strip_win32
-}
-
-src_strip_win32() {
- # need to strip win32 binaries ourselves ... should fold this
- # back in to prepstrip at some point
- local STRIP_PROG=$(mingw_CTARGET)-strip
- local STRIP_FLAGS="--strip-unneeded"
-
- echo
- echo "strip: ${STRIP_PROG} ${STRIP_FLAGS}"
- local FILE
- for FILE in $(find "${D}" -iregex '.*\.\(dll\|exe\|a\)$') ; do
- echo " /${FILE#${D}}"
- ${STRIP_PROG} ${STRIP_FLAGS} "${FILE}"
- done
-}