summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-02-08 03:39:35 +0000
committerMarien Zwart <marienz@gentoo.org>2007-02-08 03:39:35 +0000
commit2d390ac8c329d8a6ba0d8a614f9a3aa925a113eb (patch)
tree605d89bdbc4cd59af9b67e5e155c54ca554a1340 /dev-util
parentStable on amd64. Bug #165717. (diff)
downloadgentoo-2-2d390ac8c329d8a6ba0d8a614f9a3aa925a113eb.tar.gz
gentoo-2-2d390ac8c329d8a6ba0d8a614f9a3aa925a113eb.tar.bz2
gentoo-2-2d390ac8c329d8a6ba0d8a614f9a3aa925a113eb.zip
Version bump, also fixing bug #153835 (thanks to jhmartin for reporting).
(Portage version: 2.1.2-r8)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog9
-rw-r--r--dev-util/buildbot/buildbot-0.7.5.ebuild81
-rw-r--r--dev-util/buildbot/files/digest-buildbot-0.7.53
3 files changed, 91 insertions, 2 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index f6ade06ea75a..00b8d3fdccb7 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/buildbot
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.4 2006/11/02 20:03:49 marienz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.5 2007/02/08 03:39:35 marienz Exp $
+
+*buildbot-0.7.5 (08 Feb 2007)
+
+ 08 Feb 2007; Marien Zwart <marienz@gentoo.org> +buildbot-0.7.5.ebuild:
+ Version bump, also fixing bug #153835 (thanks to jhmartin for reporting).
02 Nov 2006; Marien Zwart <marienz@gentoo.org> files/buildbot.initd:
Do not say "buildslave" in the buildmaster startup script. Spotted by
diff --git a/dev-util/buildbot/buildbot-0.7.5.ebuild b/dev-util/buildbot/buildbot-0.7.5.ebuild
new file mode 100644
index 000000000000..85bf75ba4b80
--- /dev/null
+++ b/dev-util/buildbot/buildbot-0.7.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.5.ebuild,v 1.1 2007/02/08 03:39:35 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes. Similar to Tinderbox, but simpler."
+HOMEPAGE="http://buildbot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/buildbot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc irc mail test web"
+
+commondepend=">=dev-lang/python-2.3
+ >=dev-python/twisted-2.0.1"
+RDEPEND="${commondepend}
+ mail? ( dev-python/twisted-mail )
+ irc? ( dev-python/twisted-words )
+ web? ( dev-python/twisted-web )"
+DEPEND="${commondepend}
+ test? ( dev-python/twisted-web )
+ doc? ( dev-python/epydoc )"
+
+
+pkg_setup() {
+ enewuser buildbot
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
+ die "epyrun failed"
+ fi
+}
+
+src_test() {
+ local trialopts
+ if ! has_version ">=dev-python/twisted-2.2"; then
+ trialopts=-R
+ fi
+ PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+ doinfo docs/buildbot.info
+ dohtml -r docs/buildbot.html docs/images
+
+ insinto /usr/share/doc/${PF}
+ doins -r docs/examples
+
+ if use doc; then
+ doins -r docs/reference
+ fi
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildbot.initd" buildslave
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildbot.initd" buildmaster
+
+ # Make it print the right names when you start/stop the script.
+ sed -i -e '/ebegin/s/Starting buildbot/Starting buildslave/' \
+ "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
+ sed -i -e '/ebegin/s/Starting buildbot/Starting buildmaster/' \
+ "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
+}
+
+pkg_postinst() {
+ einfo 'The "buildbot" user and the "buildmaster" and "buildslave" init'
+ einfo "scripts were added to support starting buildbot through gentoo's"
+ einfo "init system. To use this set up your build master or build slave"
+ einfo "following the buildbot documentation, make sure the resulting"
+ einfo 'directories are owned by the "buildbot" user and point'
+ einfo "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
+ einfo "at the right location. The scripts can run as a different user"
+ einfo "if desired. If you need to run more than one master or slave"
+ einfo "just copy the scripts."
+}
diff --git a/dev-util/buildbot/files/digest-buildbot-0.7.5 b/dev-util/buildbot/files/digest-buildbot-0.7.5
new file mode 100644
index 000000000000..7d4a32cfe44b
--- /dev/null
+++ b/dev-util/buildbot/files/digest-buildbot-0.7.5
@@ -0,0 +1,3 @@
+MD5 86b7fad95381ce5ce2e9b8c6c56c6109 buildbot-0.7.5.tar.gz 937490
+RMD160 3aa6c243536771ed579c050d574fd57c56a96c8c buildbot-0.7.5.tar.gz 937490
+SHA256 48366fc4032487702dea95b12ddf246ca43942450924c76a60235edf9cd0b004 buildbot-0.7.5.tar.gz 937490